Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Why is CREATE_OBJECT_CLASS_NOT_FOUND ?

carlos_zhang3
Participant
0 Kudos

Dear Guru ,

I am facing a problem that the BADI class can not be executed in our Quality system . When user trigger the badi , it showed us below shortdump :


Runtime Errors         CREATE_OBJECT_CLASS_NOT_FOUND
Exception              CX_SY_CREATE_OBJECT_ERROR
Date and Time          2010.07.16 16:11:05



 Short text
     CREATE OBJECT: The class "\CLASS=ZCL_IM_IMP_BADI_MM_CHK" was not found.



 What happened?
     Error in the ABAP Application Program

     The current ABAP program "CL_EXIT_MASTER================CP" had to be
      terminated because it has
     come across a statement that unfortunately cannot be executed.

I don't understand why this happen after i tranferred the request to quality system .

When i check the class via 'SE24' tcode in quality system, it said :


Class ZCL_IM_IMP_BADI_MM_CHK	5	@0A\QError@
INCLUDE report "ZCL_IM_IMP_BADI_MM_CHK========CL" not found		

But when i checked the class in development system , everything is fine . I can't find above error message .

Could you mind to tell me the reason why this happen and how to solve this problem ?

Many thanks !!

Best Regards,

Carlos

Edited by: Carlos Zhang on Jul 16, 2010 11:41 AM

2 REPLIES 2

uwe_schieferstein
Active Contributor
0 Kudos

Hello Carlos

It is possible that something went wrong when you imported the class into your TEST system.

The error message could imply that the corresponding record is missing from table TRDIR.

I would recommend to make a small change of the class in your DEV system (e.g. change description) and transport the entire class gain into the TEST system (context menu within SE80 -> create Transport Entry for entire class).

After the import you should go to SE24 and activate the class to see if everything is ok.

Regards

Uwe

carlos_zhang3
Participant
0 Kudos

problem solved !

use se38 to active the program again !!!