Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Transaction Variant for Transaction FV60 (Parked AP Invoice)

Former Member
0 Kudos
1,594

Hi All:

I have been successful in creating a transaction variant for transaction code FV60 (Park AP Invoice). My objective was to get rid of the post and save as completed buttons on the FV60 screen. But when I simulate the document, the post and save as completed buttons appear again and I have been unsuccessful in getting rid of these and deactivating/hiding them.

Can anyone please help me or has anyone done this before?

you help is very appreciated

thanks

Brian

7 REPLIES 7

Former Member
0 Kudos
300

Hi you can hide the button as follows;

While doing SHDO Variant Creation , in the confirm screen entries dialog press Menu Functions button and in the dialog expand Function setting tree and select BU (POST) and press Deactivate button (or F2 key) then select PBBP(Save as completed) and press F2 again.

Now save the variant and activate it.

Now check the tcode, those two buttons will be hidden.

This will solve your problem.

Regards

Karthik D

0 Kudos
300

Thanks Karthik, I have done exactly as you mentioned in your message, however the post and save as complete still appear on the simulation screen. By doing what you said, the post and save as complete were removed from the screen prior to simulation NOT after simulation.

any other ideas?

thanks

Brian

0 Kudos
300

Hi,

In SHD0, open the variant in change mode and against POST and SAVE AS COMPLETED check the For Transaction Check box . Save , activate and try now.

Regards

Karthik D

0 Kudos
300

Hi Karthik,

I tried clicking 'For Transaction' check box but still the POST button is visible in Simulate Mode. Can you please guide how to hide it on Simulation Screen? It's perfectly working on first screen but not on Simulation Screen.

Thanks,

Amit

Former Member
0 Kudos
300

done thanks!

0 Kudos
300

Dear Brian Daniells

I read your thread about transaction variant on FV60,

I meet the similar problems,

I want to hide park button on fb60,fb70,

can you tell me how to hide them?

I hope can get your help...

Please see my thread as this title:

how to hide button in fb60 by transaction variant

Thanks.

Best Regards,

Harry

Former Member
0 Kudos
300

Hi All

I know I am very very late in replying to this post, but i also faced the same issue and was able to resolve it. Generally, buttons would hide in first screen but not on simulation screen(or Document Overview) after creating transaction variant. Unfortunately SAP transaction variants,when activated, does not work when Simulation screen is in Graphical Format. You need to switch over to ALV format of Simulation Screen. Run T-Code FB00 ,check "Document Overview as ALV Grid Control" and Save.  Now which all buttons you have hidden will also be hidden on Simulation Screen. However, this setting is user wise.

Regards

Saurabh Sharma