Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
Showing results for 
Search instead for 
Did you mean: 

sost - still no entry in queue after commit work

0 Kudos

Hi - We have a wrapper class(zcl_email) built around CL_BCS class and COMMIT WORK after send .

lv_sent_to_all = go_request->send( i_with_error_screen = 'X' ).

This email class(ZCL_EMAIL) is used WD application to send mails. In some cases we are getting "Still no entry in queue" error in SOST like one in a month.

Could you please help me why we are getting this issue. What could be the reason .


Active Contributor

Please and the following code at end of and see if you can see in SOST




PS: Please also note, is this is happening for any particular patter of emails or random.

Executing the above program will bring the items to SOST.

0 Kudos

Or if there are not too many emails to be sent repeatedly, you may send immediately each email via the instance method SET_SEND_IMMEDIATELY of CL_BCS, before the request is sent:

go_bcs->set_send_immediately( abap_true ).

RSCONN01 is to send in bulk, for a better performance.

Active Contributor
0 Kudos

I hope you have checked the documentation for "No entry in Queue Yet". Most likely you have an issue in your logic after creating the E-Mail and before doing the COMMIT WORK. Did you, for example, check for Dumps that coincide with those inconsistent E-Mails? Another way could be, to send the email immediately, like Sandra suggested, but that way, you only get your E-Mail out, but not the issue that you seem to have afterwards.

SAP documentation for "No entry in Queue Yet":

Send Status: Status Flag Inconsistent

A message was sent from the application. The current status of the message is 'Waiting'. However, no entry exist (yet) in the queue.


This can be a normal interim status of a sent message. Preparations for entering the message in the queue for the SAPconnect send process are complete. As soon as the Persistence Service has put the message into the corresponding database table for the queue, the status changes to 'Waiting'.

If this status stays the same for too long, an inconsistent state exists. In many cases, the cause of this lies with the sending application. The Persistence Service first writes the data to the database when the application has set an explicit Commit Work. If this is missing, then the message is not put into the queue and is not recorded by the SAPconnect send process. On the send request overview, you can put the message in the queue again using retry, but you must look for the cause of the problem in the sending application itself.

Another cause of the problem may be that the corresponding entry in the queue was deleted manually before the send process recorded the message.

Active Contributor
0 Kudos

michael.piesche I think your comment better answers the question than the current one. Can you convert it into an answer please?

Active Contributor
0 Kudos

venkata.maguluri, please follow up on your open question.

  • comment answers or your question if there are still open issues.
  • otherwise mark an answer as accepted if it helped you solve your problem
  • or post an answer of yourself and accept it if you found another useful solution yourself
  • or redirect your question to another question that is related and was useful to solve your problem
  • in the end, close your question