Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Some items of selection-screen not showing after migration to QA

Former Member
0 Kudos

Hi Folks,

I'm trying to help a colleague with something rather weird:

After migrating code-changes from our DEV- to our QA-environment (SAP_BASIS 620, SAP_APPL 470), a newly added block of the selection-screen doesn't show up. We already spent quite some time debugging and tracing in both DEV and QA but cannot really spot a difference. The new block (B2) and field (S_DATE) show up in the selection-screen internal table SCREEN and the content looks to be identical. In addition to the complete block B2 missing, the frame-title for B3 has also gone AWOL.

This is happening for a rather straighforward selection-screen definition:


SELECTION-SCREEN BEGIN OF BLOCK b1 WITH FRAME TITLE text-t01.
PARAMETERS : p_eaddr LIKE somlreci1-receiver OBLIGATORY .
SELECTION-SCREEN END OF BLOCK b1.

SELECTION-SCREEN BEGIN OF BLOCK b2 WITH FRAME TITLE text-t27.
SELECT-OPTIONS :
 s_date FOR hrp1001-endda NO-EXTENSION.
SELECTION-SCREEN END OF BLOCK b2.

SELECTION-SCREEN BEGIN OF BLOCK b3 WITH FRAME TITLE text-t23.
PARAMETERS : p_tstrun AS CHECKBOX.
SELECTION-SCREEN END OF BLOCK b3.

During debugging I already single stepped through programs like RSDBRUNT, SAPLSVAR and RSDBSPBL but nothing jumped out at me which could explain the difference between development and QA.

Do you have an idea where (else) we could look?

Thanks much and Cheers

Baerbel

1 ACCEPTED SOLUTION

Former Member
0 Kudos

Hello,

You might have to generate the program at times to make the changes made available in the Quality server. Follow the path in SE38 of QA, Program----->Generate and check if the changes are available.

Vikranth

2 REPLIES 2

Former Member
0 Kudos

Hello,

You might have to generate the program at times to make the changes made available in the Quality server. Follow the path in SE38 of QA, Program----->Generate and check if the changes are available.

Vikranth

0 Kudos

Hi Vikranth!

Thanks for your quick reply and suggestion which I immediately followed and - guess what? - it worked! The selection-screen now looks like it should.

As we never before had this type of issue it never occurred to us to just regenerate the program in QA - next time we'll know and first try this simple fix.

Thanks again!

Cheers

Baerbel