Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Simple User Exit (I don't understand..)

Former Member
0 Kudos
295

I want to test simplest User Exit:

1. I found with CMOD - SUSR0001 User exit after logon to SAP System with function module EXIT_SAPLSUSF_001 Customer-Specific Check After Every User Logon:

FUNCTION EXIT_SAPLSUSF_001.

INCLUDE ZXUSRU01.

ENDFUNCTION.

2. I created ZXUSRU01

3. I added simplest code:

----


  • INCLUDE ZXUSRU01 *

----


WRITE 'HELLO FIRST USER EXIT!'.

4. I saved and activated ZXUSRU01

5. I tryed to test. I logoned several times and I didn't see anything. I didn't see 'HELLO FIRST USER EXIT!'.

Please tell me, how can I see 'HELLO FIRST USER EXIT!'?

Edited by: Eugene on Dec 22, 2007 11:34 AM

1 ACCEPTED SOLUTION

Former Member
0 Kudos
88

its seems u've not activated the user-exit in cmod. activate it.

u need to create a project in CMOD. then add the exit no. goto components. activate it.

Reward if useful

Regards

ANUPAM

4 REPLIES 4

Former Member
0 Kudos
89

its seems u've not activated the user-exit in cmod. activate it.

u need to create a project in CMOD. then add the exit no. goto components. activate it.

Reward if useful

Regards

ANUPAM

0 Kudos
88

I created a project in CMOD - Z_PRO, added SUSR0001 in Enhancement assignment, then activated EXIT_SAPLSUSF_001 in Components.

I saved and activated project Z_PRO. I exited. I loged on and i didn't see 'hello user exit!'.

Edited by: Eugene on Dec 22, 2007 11:36 AM

0 Kudos
88

Try with Information message as follows.

message I(000) with 'hello..............................'.

Thanks and regards

0 Kudos
88

It works! Thank you!

ps: message I(000) with 'hello'. doesn't work. I used:

MESSAGE ID 'Warning' TYPE 'W' NUMBER '404' WITH 'WRONG COMPANY CODE'.