Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Sending mail EFG_GEN_SEND_EMAIL ..error in SMTP

Former Member
0 Kudos
728

Hi Friends,

I am using the FM EFG_GEN_SEND_EMAIL , for sending emails...

But after sending mail... i found it not delivered...

I have checked in trx:SCOT...found that in SMTP the messages are in Error state....

I don't know, how to see that errors...

Please help me...to solve this problem...

I did the route test in SMTP ...it is successful..

8 REPLIES 8

Former Member
0 Kudos
120

Hi,

In SCOT do like:

Go to Utilities->Overview of Send Orders

There the message statuses will be displayed. Either click on the error number or see the long text... From there u can get the reason for the error.

Hope this helps.

Regards,

Renjith Michael.

0 Kudos
120

Thanks ..

In that the error message...is ...

Internal error: SO_OBJECT_MIME_GET Exception: 2

Please help me to correct this too...

0 Kudos
120

Hi,

try setting up the default domain in transaction SCOT.

SCOT --> Settings --> Default Domain

something like gmail.com or yourcompany.com or your mail server domain itself...

Hope this helps.

Regards,

Renjith Michael.

Edited by: Renjith Michael on Apr 10, 2008 10:44 AM

0 Kudos
120

Great Renjith...

Mail sent from SAPGUI successfully..

But I am receiving "Mail Undelivered" message in my outlook..

The recepient also not receiving mail...

Any more clue....

0 Kudos
120

Hi,

As you are receiving the dalivery failure, the message should be going from SAP.

Please check the recipient ID. Hope you have given the domain as your mail server domain itself.

Then test it through the short message service. like,

go to System->Short Message->try a short massage give email id in recipients, specify type as Internet Address and see...

Regards,

Renjith Michael.

0 Kudos
120

Yes.. I have given proper domain in the Default domain...

but still i am receiving the undelivered message....

0 Kudos
120

Hi,

Check from which address the undelivered message comes... See the reason in the message.... I think it may be of the firewall settings... or if any routing restrictions are set up for your mail server...

Regards,

Renjith Michael.

0 Kudos
120

Hi Renjith,

Thanks I found this solution for the same problem via this forum

Thanks,

Lina