Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

select options query

former_member1349771
Participant
0 Kudos
103

I have defined like this :

SELECTION-SCREEN: BEGIN OF BLOCK blk WITH FRAME TITLE text-001.

SELECT-OPTIONS: s_rsnum FOR rkpf-rsnum.

SELECT-OPTIONS: s_werks FOR resb-werks.

SELECT-OPTIONS: s_matnr FOR resb-matnr.

SELECT-OPTIONS: s_bwart FOR rkpf-bwart.

SELECT-OPTIONS: s_rsdat FOR rkpf-rsdat OBLIGATORY.

SELECTION-SCREEN: END OF BLOCK blk.

still arrow is not appearing for multiple selection what can be the reason.

regards,

1 ACCEPTED SOLUTION

Former Member
0 Kudos
68

Hi,

NOthing wrong with your code.

Are the workareas/tables rkpf and resb well defined.

Regards,

Subramanian

9 REPLIES 9

Former Member
0 Kudos
69

Hi,

NOthing wrong with your code.

Are the workareas/tables rkpf and resb well defined.

Regards,

Subramanian

Former Member
0 Kudos
68

tables:rkpf,resb.

SELECTION-SCREEN: BEGIN OF BLOCK blk WITH FRAME TITLE text-001.

SELECT-OPTIONS: s_rsnum FOR rkpf-rsnum.

SELECT-OPTIONS: s_werks FOR resb-werks.

SELECT-OPTIONS: s_matnr FOR resb-matnr.

SELECT-OPTIONS: s_bwart FOR rkpf-bwart.

SELECT-OPTIONS: s_rsdat FOR rkpf-rsdat OBLIGATORY.

SELECTION-SCREEN: END OF BLOCK blk.

Now is is appering arrows.Please check now with this code.

Reward Points..

Former Member
0 Kudos
68

HI,

Your code is correct, it will work fine (activate it and try once again).

former_member1349771
Participant
0 Kudos
68

s_rsnum FOR rkpf-rsnum.

as i changed to s_rsnum FOR resb-rsnum it started working thanks for ur reply.

regards,

Former Member
0 Kudos
68

Hi,

code is fine.

Just declare the tables .

Tables : rkpf, resb.

regards,

Dhan

former_member195383
Active Contributor
0 Kudos
68

Nothing wrong with the code u have written...

I have pasted the same code that u have written and it working fine...try activating ur program once more....

and use

tables : rkpf, resb.

before the code

Edited by: Rudra Prasanna Mohapatra on Jun 19, 2008 8:31 AM

Former Member
0 Kudos
68

Hi,

You are correct

u declare rkpf,resb as tables.

tables : rkpf,resb.

SELECTION-SCREEN: BEGIN OF BLOCK blk WITH FRAME TITLE text-001.

SELECT-OPTIONS: s_rsnum FOR rkpf-rsnum.

SELECT-OPTIONS: s_werks FOR resb-werks.

SELECT-OPTIONS: s_matnr FOR resb-matnr.

SELECT-OPTIONS: s_bwart FOR rkpf-bwart.

SELECT-OPTIONS: s_rsdat FOR rkpf-rsdat OBLIGATORY.

SELECTION-SCREEN: END OF BLOCK blk.

You check it again.

former_member1349771
Participant
0 Kudos
68

s_rsnum FOR rkpf-rsnum.

as i changed to s_rsnum FOR resb-rsnum it started working thanks for ur reply.

Former Member
0 Kudos
68

Hi,

just copy the code and paste in another program.

Nothing wrong in ur code.

Declare rkpf,resb tables before selection options..

Regards ,

Ranjith C