Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Search help - Make a field default without grey-out

Peter_Inotai
Active Contributor
0 Kudos

Hi,

I have a custom-search help, where in the dialog-popup I'd like to default a value without grey-out.

If I import from memory via parameter ID, then the default value is ok, but it's greyed out.

If I don't import it, then it's initial, but not greyed out.

Is it possible?

Thanks,

Peter

1 ACCEPTED SOLUTION

Former Member
0 Kudos

Remove the importing parameter check box.

In the default dont type the hard codes value using " ", instead type the parameter id directly MTA without quotes ( MTA is parameter id for MTART , material type , just an example ). Now test it should work . I tried and it work the way you desire.

Cheers

8 REPLIES 8

Former Member
0 Kudos

Hi,

Make sure the Display Checkbox in search help definition is not checked.

Normally it is not greyed out even if you take it from a parameter id.

Sri

0 Kudos

Thanks Sri!

I double checked, but it's unflagged.

Peter

Former Member
0 Kudos

Whtether you set it by PARAMETER or using default value column in search help definition, it will be greayed out .

Former Member
0 Kudos

Ok if the parameter which you want to default is an import parameter then it will be grayed out. It it is exp parameter only then you can achieve the desired result. Just uncheck the IMP parameter.

Hope this helps.

Cheers.

Former Member
0 Kudos

Hi Peter,

Are you using a Search Help exit for importing from memory or the Default column in the search help definition?

If it is the second option then it should not get greyed out. (I just tried it before replying).

And there is no need to uncheck importing flag as sanjay said. It has nothing to do with this.

Sri

0 Kudos

Hi Sri & Sanjay,

Thanks a lot for your help.

Unfortunately I cannot use the default value, as this should be dynamic based on another field on the screen. I tried if I use default, and it's not greyed-out.

If I use IMP flagged, or import this value in the user exit from memory, then it's always greyed-out.

It seems it's not possible unless I create my screen in the pop-up.

Thanks,

Peter

Former Member
0 Kudos

Remove the importing parameter check box.

In the default dont type the hard codes value using " ", instead type the parameter id directly MTA without quotes ( MTA is parameter id for MTART , material type , just an example ). Now test it should work . I tried and it work the way you desire.

Cheers

0 Kudos

It works perfectly, thanks a lot.

Actually it's mentioned in the F1 help of the fields, I just didn't noticed yet:

"There are the following options for the default values:

...

c) The ID of a GET parameter."

Thanks,

Peter

PS: I'll try to give you the points, now I'm just getting the message "Rewarding the message failed."