Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Search help at a structure field does not appear

Former Member
0 Kudos
89

Hi there,

i have created a customer own search help and for a first try i have assigned it to a screen field. This worked propperly but i receive values for three fields (document number, company code and fiscal year) from that search help - what has been succesfully testet in SE11 and worked ok.

To assign all exporting fields to my screen I deleted the search help at the screen field and I created a copy of RF05L structure and assigned my search help to the document number there. My screen fields belong now to a structure and the type of that structure is my version of RF05L, at first with type, later changed to like.

So my screen field must have the search help from that structure, but it has no search help at all.

After some trials I deleted my field from the screen and added it again based on my structure and changed the name to my internal structure name for the document field. This was the only trial where the search help appeared afterwards but as I did the same to the two other fields it disappeared again and I could not make it visible until now.

What shall I do?

Thank you in advance for any hints.

1 REPLY 1

Former Member
0 Kudos
21

Hi Axel,

When you are adding the screen fields - are you sourcing them from the Program OR Data dictionary.

You should source it from the Data Dictionary and ensure the screen fields attribute "From Dict." checkbox is marked in the "Dict" tab.

Hope this helps.

Regards,

Aditya