Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem in sending mails from SAP-line breaks in lotus

Former Member
0 Kudos

Hi Gurus,

I have a very peculiar issue with external mail send from SAP to Lotus Notes.

Issue: When a PO is created in SAP a automatic mail will be sent to vendor to his

Lotus Notes from SAP. Here we are a using a subroutine where the FM

'SO_NEW_DOCUMENT_SEND_API1' and the content of the mail is stored in text symbols

and then populated to a internal table which will be passed to the above said FM.

So this is very simple case.

My problem is now, even though it looks fine in the SOST, when mail is seen in lotus,

lines of the mail contents are breaking around 79th or 80th character, eventhough it is more than

that while appending to the internal table. I don't understand this at all, why it is happening?

Ex: in SOST if we see a line looks like this.

aaaaaaaaaaaaaaaaaaaaaaaaaabbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbnnnnnnnnnn

but in lotus it breaks and looks like below:

aaaaaaaaaaaaaaaaaaaaaaaaaabbbbbbbbbbbbbbbbbbbbbbbbbbbb

bbbbbbbbbbbnnnnnnnnnn

Any light can be thrown on this!!!

Reward is guaranteed for helpful answers!!!!

-B S B

1 ACCEPTED SOLUTION

Former Member
0 Kudos

How do you connect SAP to the lotus notes email database? In some installations I have seen this done using Unix Sendmail functionality and this may be causing this result?

Andrew

1 REPLY 1

Former Member
0 Kudos

How do you connect SAP to the lotus notes email database? In some installations I have seen this done using Unix Sendmail functionality and this may be causing this result?

Andrew