Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Proble in VA01, cant see condition types in condition tab at item level

Former Member
0 Kudos
103

Hi

Well i am facing a strange problem in VA01, i am not able to see condition type whole grid under Condition tab at item level in VA01. actually i was given a project to hide pricing data from particular users based upon Authorization object value. initially i though it might be because of that so i revert back all the changes but the problem remain Intact.

well do you have any idea which user exit or enhancement may affact this or do you knoe if it can be because of SD configuration changes.

i mean can be hide condition type in VA01 through pricing condition.

the other thing is its working fine in VA02.

i made changes in following include

MV45AFZZ

MV45AFZB

LV69AFZZ

RV60FUS4

any help will be highly appreciated .

rewards for sure

mandy

Edited by: mandy on Jan 15, 2008 2:11 PM

2 REPLIES 2

Former Member
0 Kudos
43

STILL PENDING

0 Kudos
43

use this

INCLUDE MV45AFZZ. include.

u will find FORM USEREXIT_PRICING_PREPARE_TKOMK

where u can change

princing

i am puting my code which i did

ok

DATA : WA_KOMV LIKE XKOMV,

WA_ZPRICING LIKE ZPRICING1.

IF SY-TCODE = 'VA01'.

IF VBAK-AUART = 'YYOR'.

LOOP AT XKOMV INTO WA_KOMV where KPOSN = VBAP-POSNR.

IF WA_KOMV-KSCHL = 'ZABS'.

SELECT SINGLE *

FROM ZPRICING1

INTO WA_ZPRICING

WHERE VKORG = VBAK-VKORG

AND VKBUR = VBAK-VKBUR

AND VTWEG = VBAK-VTWEG

AND MATNR = VBAP-MATNR.

IF SY-SUBRC = 0.

delete XKOMV.

ENDIF.

ENDIF.

ENDLOOP.

ENDIF.

ENDIF.