Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

POPUP_GET_VALUES Field is grayed out.

former_member612750
Participant
0 Kudos

Hi,

I have used the FM POPUP_GET_VALUE and created my own structure and own data element the first data element for the first field is like VERPR or Moving Average Price and the Second one is like TCURR or Currency. But it seems like I cannot input any values in the first field (VERPR) can anyone help me regarding this.

DATA : ld_returncode TYPE STRING,
t_fields TYPE STANDARD TABLE OF SVAL,
wa_fields1 LIKE LINE OF t_fields,
wa_fields2 LIKE LINE OF t_fields.

wa_fields1-tabname = 'ZVALCURTAB'.

wa_fields1-fieldname = 'ZVALUE'. "Data Element Like VERPR this is grayed out.
wa_fields1-field_obl = 'X'.
wa_fields1-value = '5000'.
append wa_fields1 to t_fields.


wa_fields2-tabname = 'ZVALCURTAB'.
wa_fields2-fieldname = 'ZCURRENCY'.

wa_fields2-field_obl = 'X'.
wa_fields2-value = 'USD'.
append wa_fields2 to t_fields.

CALL FUNCTION 'POPUP_GET_VALUES'
EXPORTING
popup_title = 'Enter Local Capital Threshold Criteria'
start_column = 5
start_row = 5
IMPORTING
returncode = ld_returncode
TABLES
fields = t_fields
EXCEPTIONS
ERROR_IN_FIELDS = 1
. " POPUP_GET_VALUES

IF SY-SUBRC EQ 0.
"All OK
ENDIF.

4 REPLIES 4

mateuszadamus
Active Contributor

Hi catienza11

Can you share your code, please? It would make helping you a lot easier.

regards,
Mateusz

former_member612750
Participant
0 Kudos

I have edited my question, the field like VERPR is grayed out and I cannot input any value is this something in Data Element?

mateuszadamus
Active Contributor
0 Kudos

Hi catienza11

At this moment I'm not able to reproduce the issue.

Please check the definition of fields in your structure. The TCURR type, which you mention, is actually a transparent table, not a data element. Maybe this is an issue?

Are you sure that FIELD_ATTR field in the definition of ZVALUE field is empty?

regards,

Mateusz

mateuszadamus
Active Contributor

Could you paste the structure definition?