Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Parameter ID's in User Exits

Former Member
0 Kudos

Hi All,

I have a problem with the parameter URG for user groups of HR infotypes and subgroups, because I am in a implementation, so in the user exits ZXPADU01 and ZXPADU02 there are somo validations that I wanna avoid, so I don't wanna do it by user names because are a lot, so I wanna do it by User Group of infotypes, so I get the parameter, but it doesn´t get it, it´s empty. please help me with this, tell what can I do. may be exists a table where I can read the user group or something like that I really don´t know.

Thanks.

This is my code.

&----

-


*& Include ZXPADU01

&----

-


DATA: idugr TYPE PME04-USERG.

GET PARAMETER ID 'UGR' FIELD IDUGR.

IF IDUGR NE 99.

case innnn-infty.

---

---

endcase.

endif.

Edited by: Julius Bussche on Jul 14, 2008 12:38 PM

Please use a meaningfull subject title

1 ACCEPTED SOLUTION

former_member188685
Active Contributor
0 Kudos

Check this parameter id 'UGR' is containg any value.

GET PARAMETER ID 'UGR'

are you populating any value before calling the get parameter.

if the value is iniital then nothing will come.

Or Assign some default value in your user setting and check problem still there or not .and let me know.

3 REPLIES 3

former_member188685
Active Contributor
0 Kudos

Check this parameter id 'UGR' is containg any value.

GET PARAMETER ID 'UGR'

are you populating any value before calling the get parameter.

if the value is iniital then nothing will come.

Or Assign some default value in your user setting and check problem still there or not .and let me know.

0 Kudos

Hi Vijay,

I set a parameter before to do the get parameter, and it seems to be ok if I feel it before by myself, but it suppose to be filled by the standard sap, but I don´t know why doesn´t feel it. It´s a hugh problem, I don´t know if I can read this parameter from some table or something like that accessing by the number infotype...

Look in this way this works, but I just wanna do the get parameter.. =(

DATA: idugr_i TYPE USERG, "pme27-userg, " PME04-USERG.

idugr_o TYPE USERG. "pme27-userg.

idugr_i = '99'.

SET PARAMETER ID 'UGR' FIELD idugr_i.

GET PARAMETER ID 'UGR' FIELD idugr_o.

It works, but it must be feelling by the standard not by me.. =( Please Help..

former_member194669
Active Contributor
0 Kudos

Have you checked your parameters tab in transaction code SU3 ?

May be it is get fill from there.