Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
Showing results for 
Search instead for 
Did you mean: 

OPEN_DATASET_NO_AUTHORITY abap runtime errors

Former Member


I have a custom ABAP program which outputs a file to UNIX and then FTP this file to a NT share drive. I have no problem executing this program using my ID. I checked using AL11 that the creator of the file in UNIX is DEVADM & not my user id.

However ,when my user uses this same program to execute, she gets an ABAP runtime error "OPEN_DATASET_NO_AUTHORITY" and the error points to failure at this statement








open dataset filelocation for output in text mode.

It says that the user does not have authorization for this.

Can someone advise me on what authorization I should add in for the user using PFCG Change activity group?

I tried adding the S_DATASET object in the AG.


Manually Basis: Administration BC_A

Manually Authorization for File Access S_DATASET

5 Manually Authorization for File Access T-DV48009400

Activity 33, 34 ACTVT

Physical file name Assets* FILENAME

ABAP program name YZFAU007 PROGRAM


but during transportation of this activity grup using SCC1 i got the error. Can sonmeone please advise me the right way to resolve this problem? Thanks!


No authorization to change file /usr/sap/trans/log/CC004492.DEV

Message no. PU 808


When working with the Workbench Organizer, you tried to access certain

operating system files to change them.

To avoid competing file accesses, semaphore files are created beforehand

which are deleted again when the respective file change has been


You are not authorized to delete such semaphore files. To avoid

inconsistencies and deadlocks, creation of semaphore files as well as

the actual file access required is forbidden in this case.

System Response

The function is terminated.


The file access authorizations are assigned via the authorization object


First obtain the authorizations generally provided for this object if

you want to work with the Workbench Organizer.


Former Member
0 Kudos

Chk the Notes.

56024, 850234, 1064169

ALso chk the below thread.

0 Kudos

hi, I read throught the sap notes, 1st one not avail, 2nd one requies BW support package, last one is sql truncate table note which don't look relevant.

I read through the other thread, my purrpose is not to restrict or catch the error, my purpose is to add authorization for my user so that she is able to run '----> open dataset filelocation for output in text mode' without the open_dataset_no_authorization runtime error.

I have already added in the S_dataset object in the AG,

Manually Authorization for File Access

Activity Read, Write

Physical file name Assets*

ABAP program name YZFAU007

but i encountered error during transport SCC1 as indicated above, so I wonder if the PFCG change AG is right.

Former Member
0 Kudos


check the transection SU53 and note down the authorization problem, if any.

Hope it helps.



0 Kudos

right after the error msg, i executed SU53 and get this error

'You are not authorized to use transaction SU53'

However, during normal circumstances, am able to execute SU53 in the system. Only right after this error msg i cannot access the transaction. After exit and relogin i am able to.