Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Missing requirement: ABAP Core 2.94.4 in Eclips

mahabaleshwar_patil
Participant
0 Kudos

Hi All

I am unable to install the ABAP in eclipse . When I click on install software and provide the link https://tools.hana.ondemand.com/oxygen


Cannot complete the install because one or more required items could not be found. Software being installed: ABAP Core Development Tools (Developer Edition) 2.94.7 (com.sap.adt.core.devedition.feature.group 2.94.7) Missing requirement: ABAP Core 2.94.4 (com.sap.adt.activation.ui 2.94.4) requires 'bundle org.eclipse.emf.workspace [1.5.1,2.0.0)' but it could not be found Cannot satisfy dependency: From: ADT Blue SDK (UI) 2.94.4 (com.sap.adt.blues.core.ui 2.94.4) To: bundle com.sap.adt.activation.ui [2.93.0,3.0.0) Cannot satisfy dependency: From: samc Model 1.26.0 (com.sap.adt.conn.amc.ui 1.26.0) To: bundle com.sap.adt.blues.core.ui [2.93.0,3.0.0) Cannot satisfy dependency: From: ABAP Connectivity 1.26.0 (com.sap.adt.conn.feature.group 1.26.0) To: com.sap.adt.conn.amc.ui [1.26.0] Cannot satisfy dependency: From: ABAP Core Development Tools (Developer Edition) 2.94.7 (com.sap.adt.core.devedition.feature.group 2.94.7) To: com.sap.adt.core.feature.group [2.94.7] Cannot satisfy dependency: From: ABAP Core Development Tools 2.94.7 (com.sap.adt.core.feature.group 2.94.7) To: com.sap.adt.conn.feature.group [1.26.0]

2 REPLIES 2

SimoneMilesi
Active Contributor
0 Kudos

Hi!

Which Eclipse version are you using?
i just installed ADT on my Eclipse Photon on my new laptop using Oxygen link, without any problem.
Did you select all the checkboxes? Only some? Which ones?

PS.

Do not open multiple questions on the same topic: it will be a chaos for people trying to help you and for yourself too : )

matt
Active Contributor
0 Kudos

Question already exists here: https://answers.sap.com/questions/623170/unable-to-install-abap-in-eclips-by-using-install.htmlThis one is now closed.


Please do not post duplicate questions.