Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Issue with VOFM routine activation

Former Member
0 Kudos

Hi Gurus,

I created a routine 901 for Req. Availability for Class FOFU in VOFM.

As i did same as in other threads mentioned...

1. Creation with access key

2. Code written with Insert

3. Activated the LV07A901 include

4. Run the report RV80HGEN - All includes activated message

5. go to program SAPLV07A - rebuild object list

then i checked TFRM table the routine is not active and i cant see my include too.

Is there anything done by functional guy or am i did anything wrong?

Giri

4 REPLIES 4

former_member191735
Active Contributor
0 Kudos

> I created a routine 901 for Req. Availability for Class FOFU in VOFM.

>

> As i did same as in other threads mentioned...

>

> 1. Creation with access key

> 2. Code written with Insert

> 3. Activated the LV07A901 include

> 4. Run the report RV80HGEN - All includes activated message

Everything is good till this point....

> 5. go to program SAPLV07A - rebuild object list

>

What are you doing here? Why do you need to rebuild object list?

> then i checked TFRM table the routine is not active and i cant see my include too.

>

> Is there anything done by functional guy or am i did anything wrong?

Nothing required from functional

Could you copy the 101 to 901 and make modifications..... and make sure you have added syRoutine in VOFM

Former Member
0 Kudos

Giri,

In the VOFM transaction screen you should see a column which denotes whether your routine 901 is active or inactive. If it is inactive select/highlight the 901 routine and go to the menu on the top of VOFM transaction and activate it.

Also do a where used list of LV07A901 and it should display the SAPLV07A as its main program.

Naresh

Former Member
0 Kudos

Hi,

Functional consultant do the same in Configuaration client.. not in Dev client.

Then he will transport same into Dev. That is the procedure we should follow.

regards,

Ajay

0 Kudos

That is if the config client and dev client is different. In this case it is question of activation but not the configuration