Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

How to add feildes to standerd table.

Former Member
0 Kudos

Hi Mates.

Iam new to ABAP, could u help me , how to add extra feidls to standerd tabke( Exp .KNA1).

Regards.

harry

1 ACCEPTED SOLUTION

Former Member
0 Kudos

hi,

I think you need not be in change mode for that in the main table. Once you have appended that structure through Append structure, you can go in change mode in that structure and try adding the fields.

Regards,

Kalpana

18 REPLIES 18

former_member188685
Active Contributor
0 Kudos

hi use Append structure or include structure in se11

type kna1 and use append structure or Include structure.

structure shuld contain the fields which you need to add .

regards

vijay

manuel_bassani
Contributor
0 Kudos

Hi,

you should add an append structure to KNA1. In transaction SE11

Goto->Append structure...

It creates a custom structure at the end of KNA1. Inside the append structure you can add custom fields.

Remember to reward points for useful answers

Regards, Manuel

Former Member
0 Kudos

Former Member
0 Kudos

HI VIjay &Manuel.

yes i hv tried with append or include feild in se11 ,but it asking me access key, iam trying in own laptop. so how i can add feild to table.

redards.

harry

Former Member
0 Kudos

Harry,

There are two ways to add new fields into KNA1 table.

1. Through APPEND Structure

GOTO --> APPEND Structure

2. Through INCLUDE Structure

EDIT --> INCLUDE --> Insert

The above paths are valid only when u r in the Initial Screen of KNA1 using SE11.

<b>KNA1 is a standard table. So it is better to go with APPEND Structure</b> instead of INCLUDE.

Thanks

Kam

0 Kudos

Hi KAM.

yes, i know little , what u hv told me , but when i try to chang KNA1, it asking me access key.do u know , what i hv to do now

0 Kudos

hi

Don't Go to Change mode only in display mode do it.

regards

vijay

0 Kudos

Harry,

<b>U do not want to Change the mode from the DISPLAY to CHANGE!!!!!</b>

In the display mode, click GOTO --> APPEND Structure!!!!

U can able to add APPEND Structure without ACCESS KEY!!!

Thanks

Kam

Former Member
0 Kudos

hi,

I think you need not be in change mode for that in the main table. Once you have appended that structure through Append structure, you can go in change mode in that structure and try adding the fields.

Regards,

Kalpana

0 Kudos

Hi ya.

Let me try this i wll come back to you guys.

thanks vry much.

harry

0 Kudos

Hi Please Reward Points and close the thread if your problem solves.

regards

vijay

Former Member
0 Kudos

Hi,

You can use both Append Strucutre & CI include .

But their is a significant difference between these two.

If you use CI include you can use this field in other tables also.

If you use Append Structure then the field pertians to

this table itself.

If you find the answer suitable please reward suitable point's and close the thread.

Regards,

Irfan Hussain

0 Kudos

hi Irfan

iam getting problem to append my KNA1table, when i try u append table , it asking zakna1 strucutrue, after adding feelds to structure,and data eleement , when i try to activate structure, its giving me errors.

thks

harry

0 Kudos

Harry,

What Error messages u get ????

If u have created new Z Data Element or domain, Have u activated it before Activating the APPEND Strcuture????

Thanks

Kam

Message was edited by: Kam

0 Kudos

Hi In menu bar choose UTILITIES

in that DATABASEUTILITY click on that

and then click on activate and adjust databse.

With out changing any thing

then activate.

regards

vijay

0 Kudos

HI guys.

iam created zakna1 structure, i hv givn 2 feilds with data element , when i try to activate , its giving me 2 errors.

1)assian a normal development class to the object.

2)field 'phoneno' doen not lie with in customer name space

regards

harry

0 Kudos

Harry,

1. Check whether u have all the Data Elements are either sitting in a Transport Request or saved in the Developmenmt Class ??? If not make it fall inside the Transport Request.

2. Phoneno should be named as <b>Zphoneno</b>.

Thanks

Kam

abdul_hakim
Active Contributor
0 Kudos

Hi Harry.

Use Append structure..

Abdul