Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

how can i conversion English to Chinese?

Former Member
0 Kudos

Hi Experts,

this is my test program :

REPORT test .

tables : spfli , sflight .

start-of-selection .

skip .

ULINE AT /(91) .

write 😕 sy-vline , (15) ''(001), sy-vline ,

(15) '????', sy-vline ,

(15) '????', sy-vline ,

(15) '????', sy-vline ,

(15) '????', sy-vline .

ULINE AT /(91) .

select * from spfli .

write : / sy-vline , (15) spfli-carrid , sy-vline ,

(15) spfli-connid , sy-vline ,

(15) spfli-countryto , sy-vline ,

(15) spfli-cityfrom , sy-vline ,

(15) spfli-airpfrom , sy-vline .

hide : spfli-carrid , spfli-connid .

ULINE AT /(91) .

endselect .

at line-selection .

if sy-lsind = 1 .

select * from sflight

where carrid = spfli-carrid and connid = spfli-connid .

write : / sflight-carrid , sy-vline ,

sflight-connid , sy-vline ,

sflight-fldate , sy-vline ,

sflight-price .

endselect .

endif .

when I press pretty printer ,Chinese has become ???? , and the result is also ???? , I have try to make text element ,just like 001 航班承运人 ,but also have this problem.

Please help me .

THX!

1 ACCEPTED SOLUTION

former_member195383
Active Contributor
0 Kudos

Hi Frank,

This problem is occuring bcoz' the system's codepage is unable to

Recognise the perticular characters, and is converting them to question mark....

The solution is go to translations and maintain the same.

If the characters are still not appearing then the below scenarion..may be the reason..

Some times the development systems codepage is different that the higher systems..i.e. quality and production systems...In that case..even if the characters are not coming in the development system..the same may come in the higher system...

Reward points...if the above ans is useful..

Regards

Rudra

11 REPLIES 11

Former Member
0 Kudos

Hi,

Have you login in English?

Then make text element in english.

then goto GOTO--> TRanslations.

Give target language as chinese. and copy the correspondin chinese text to text elements there.

Save. And activate the program.

Then login in Chinese language.

text will appear fine.

Reward pts if helpfull.

Regards,

Dhan

0 Kudos

I see,although in my goto menu I can'nt find what you said , the problem just you sai is login language

thank you for you answer

Former Member
0 Kudos

check what source language is the report.

open the report in editor using SE80.

Use menu Goto->Translation. Enter source and target language.

All texts are displayed for translation.

0 Kudos

thank you for your answer,but in my system the goto menu only have "back".

0 Kudos

hi,

initially if u see goto it will have only back option,just select ur program by double clicking and then use goto - translation option.

hope this will help u.

reward points if hlpful.

former_member195383
Active Contributor
0 Kudos

Hi Frank,

This problem is occuring bcoz' the system's codepage is unable to

Recognise the perticular characters, and is converting them to question mark....

The solution is go to translations and maintain the same.

If the characters are still not appearing then the below scenarion..may be the reason..

Some times the development systems codepage is different that the higher systems..i.e. quality and production systems...In that case..even if the characters are not coming in the development system..the same may come in the higher system...

Reward points...if the above ans is useful..

Regards

Rudra

0 Kudos

just like what you say , the problem is the login language ,when I login ZH and change the words , the prbolem is solution .

Former Member
0 Kudos

Hi,

Go to SE63

here you can convert english to chinese.

Thanks

0 Kudos

sorry , i have no reference to open SE63

Former Member
0 Kudos

Hi,

Thx for the pts.

Once you open the program in display or change mode then click on GOTO. There you will find the option 'Translations'.

Regards,

Dhan

0 Kudos

thank you for you tips ,but unfortunately the information is "Language not available on server"