Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

getting junk characters when uploading japanese data in input file

Former Member
0 Kudos
303

Hi

i have input files which are having some of the fileds with japanese characters. when i upload that into internal table i am getting junk characters against that fields .

can any one please tell me what is the exact process i have to do in my coding / settings so that i can get data as it is from the inputfile and upload into my internal tabe.

regards

rajani

1 ACCEPTED SOLUTION

Former Member
0 Kudos
115

setting for installing language

-


1.GO TO CONTROL PANEL -> REGIONAL AND LANGUAGE OPTION -> LANGUAGE TAB -> CHECK THE 2ND CHECKBOX -> TAB ADVANCED->

SELECT THE LANGUAGE TO BE INSTALLED OR CHECK THE CHECKBOXED BELOW TO THAT BASED ON OPERATING SYSTEM (MINE IS WINDOWS XP)

NOT WINDOWS 2000.

RESTART THE COMPUTER AFTER INSTALLATION.

2.THEN GO SAP LOGIN AND GO TO TAB->CUSTOMIZING OF LOCAL LAYOUT -> OPTIONS->118N->CHECK THE CHECKBOX.

3. when using WS_UPLOAD / WS-DOWNLOAD add the parameter code-page = ‘8000’.

THEN WILL WORK THE JAPANESE LANGUAGE.

3 REPLIES 3

Former Member
0 Kudos
115

Hello,

This is the problem with the GUI setting.

In the SAP menu go to Options.

Choose the I18N tab.

Check the Activate multifunctionality support .

Then logoff as well restart ur system.

Then upload u will see all the characters.

REgards,

Vasanth

Former Member
0 Kudos
115

u need to install japanese translation in ur SAP system.

goto ur sap screen and in menu bar u find "Customizing of local layout". click on options and in one of tab I18N, select the checkbox and press apply & ok. logoff and login again and check for the upload.

Former Member
0 Kudos
116

setting for installing language

-


1.GO TO CONTROL PANEL -> REGIONAL AND LANGUAGE OPTION -> LANGUAGE TAB -> CHECK THE 2ND CHECKBOX -> TAB ADVANCED->

SELECT THE LANGUAGE TO BE INSTALLED OR CHECK THE CHECKBOXED BELOW TO THAT BASED ON OPERATING SYSTEM (MINE IS WINDOWS XP)

NOT WINDOWS 2000.

RESTART THE COMPUTER AFTER INSTALLATION.

2.THEN GO SAP LOGIN AND GO TO TAB->CUSTOMIZING OF LOCAL LAYOUT -> OPTIONS->118N->CHECK THE CHECKBOX.

3. when using WS_UPLOAD / WS-DOWNLOAD add the parameter code-page = ‘8000’.

THEN WILL WORK THE JAPANESE LANGUAGE.