Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Functions does not work under NetWeaver 7.0.2 ?

Former Member
0 Kudos
72

Hello,

I am new on SAP ABAP

I created a function when I testt,  it is OK , but  when I call  it in a report it does not work. I developped  under SAP netweaver 7.02.

Please you help me?

4 REPLIES 4

raymond_giuseppi
Active Contributor
0 Kudos
46

Check the format of parameter. When you test using SE37 conversions are executed for fields with conversion-exit or date/time fields, in your report the data must already been in internal format. If that don't solve your problem, please provide more information.

Regards,

Raymond

UweFetzer_se38
Active Contributor
0 Kudos
46

 it does not work

What does this mean? A dump? False output?

I don't think you will get a correct answer, if your question is such vague.

Best regards

Former Member
0 Kudos
46

Hello,

I learn ABAP on SAP NetWeaver Application Server ABAP 7.02 SP6 64 - bit Trial, I created a function  and when I test it under se37 I have a good result . When I call it in a repport, it does not give the expected result.

I tried everything and I am surprised enough, is the trial version limited?

Thank you for your answers

Marcel Elimby

0 Kudos
46

Hi Marcel,

no, the trial version is not limited.

Can you please post your code (the Function Module interface) and your call in the report? It's very hard to guess what's wrong without further information.

Regards