Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Error while tranporting the Transport Request into UAT system?

Former Member
0 Kudos

Hi all,

I have created two function moduels in the same function group, and captured that in one TR.

But for some reason i have deleted one function module from the TR and not from the Functin Group.

While tranpsorting it into other system like QA and UAT we got the error as 'the delted function module can not be found".

So again i have deleted that function module from the function group and saved it in a new tr.

When we tried to import transport also it's giving the same error.

But when i checked for the code that function module is not there in QA system but it's there in UAT.

Only include is there not actual code.

So when the user executes the program it's referring to the deleted function module and giving an error as syntax error in program.

Please advise on this.

Thanks a lot in advance....

2 REPLIES 2

Former Member
0 Kudos

To fix a function group....  get it compiled and activated in your development instance, as you want it...then in your transport, add the group (available in your drop downs or in the objects list),

Add R3TR, FUGR and your function group name....  This will "repair" the function group as you transport into other instances. 

0 Kudos

There is also a "repair" option in the menu of SE37.

Regards,

Raymond