Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Email always sent as High priority using CL_BCS

Former Member
0 Kudos

I'm using the BCS classes to send email to trade partners. Some trade partners receive the emails as high priority (Ex. xxxx@yahoo.com)even though the priority is set to low. I am creating the document as follows:

document = cl_document_bcs=>create_document(

i_type = 'RAW'

i_importance = '9'

i_text = lt_textbody

i_length = lv_len_textbody

i_subject = cv_subject ).

This is occurring whether I set i_importance = 1 thru 9.

Is there possibly a SAPConnect setting that controls this?

1 ACCEPTED SOLUTION

thomas_jung
Developer Advocate
Developer Advocate
0 Kudos

In my system (640 SP10) sending email to myself (Microsoft Exchange and Microsoft Outlook XP), the i_importance attribute seems to have no effect at all. No mater what I set it to it doesn't control the level of importance that displays in my mail reader.

The only way that I have found to make the email appear with a high importance, is to set the i_express attribute when I add my recipient to the send request.

  • Add recipient with its respective attributes to send request

CALL METHOD send_request->add_recipient

EXPORTING

i_recipient = recipient

i_express = 'X'

i_copy = ' '

i_blind_copy = ' '.

Perhaps this is what your users are experiencing.

2 REPLIES 2

thomas_jung
Developer Advocate
Developer Advocate
0 Kudos

In my system (640 SP10) sending email to myself (Microsoft Exchange and Microsoft Outlook XP), the i_importance attribute seems to have no effect at all. No mater what I set it to it doesn't control the level of importance that displays in my mail reader.

The only way that I have found to make the email appear with a high importance, is to set the i_express attribute when I add my recipient to the send request.

  • Add recipient with its respective attributes to send request

CALL METHOD send_request->add_recipient

EXPORTING

i_recipient = recipient

i_express = 'X'

i_copy = ' '

i_blind_copy = ' '.

Perhaps this is what your users are experiencing.

0 Kudos

Thanks Thomas!

That was the problem.

Brant