Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Debugging stored procedure: 'Edit Source Lookup Path' (and source not found)

Former Member
0 Kudos

I have this AMDP generated procedure that I am trying to debug, but for some reason the debugger is not stopping as it is supposed to do despite having followed the instructions provided in

Hence, instead I created a catalog procedure (ZTEST2) which I am now attempting to debug as described by Rich Heilmann in this video  SPS7 Catalog Debugging - YouTube

Unfortunately also this does not work as expected and the debugger is stoppiingI at the breakpoints, but all I see is the mesage 'Edit Source Lookup Path...' (pls see screenshot below).

Important to note: procedure ZTEST2 calls the AMDP generated procedure which I am unable to debug in the normal fashion (it is used as a wrapper procedure since there are populated tables as parameters to the AMDP procedure).

Maybe since ZTEST2 calls an AMDP procedure (which is linked to an ABAP class) the debugger is looking for the path to that class somehow.

I have tried all the entires offered in the window below to the right (multiple select is possible), but to no avail.

12 REPLIES 12

Former Member
0 Kudos

Have you verified your Debug Configuration settings in the stored proc? As per the Tutorial, I reckon you'll need to ensure that you have the users set up correctly and appropriate authorizations granted to them. Also, check if the system mentioned under SAP HANA System is as per your system settings.

Cheers

S.

0 Kudos

Shipra,

what is the "Debug Configuration settings in the stored proc" that you are referring to?

Thanks

christian_seitel
Participant
0 Kudos

Can you reproduce the first screenshot in "How to debug an AMDP", i.e. with the DEBUGUSER can you display the 'create procedure ..." statement of the AMDP. (Maybe some grant is missing here). The problem is not related to ABAP at all, so you may consider to post that "Source not found" problem in the HANA community. (I don't think there is a source file at all for non-catalog procedures. HDB only keeps SQL-create statement.) What's at line 7 of ZTEST2 ? The call of the AMDP ?

0 Kudos

Christian,

attached you find a PPT with screenshots of the 3 procedures (ztest2->MY_HANA_PROCEDURE->ztest).

To open please rename

from: Debugging stored procedure.pptx.txt

to:    Debugging stored procedure.pptx

Your question: "What's at line 7 of ZTEST2 ? The call of the AMDP ?"

Answer: No, the call to the AMDP is on the next line. Line 7 is the statement t_temp = select from "SAPHANAABAP"..... (pls see screenshot)

I have x-posted this thread in SAP HANA and In-Memory Computing and  SAP HANA Developer Center

but received no answers yet (which I reckon is normal since it seems that response time in those communities is slower).


I appreciate your attention to this. Thanx!

0 Kudos

Sorry I oversaw your request for the screenshot, but here it is:

Former Member
0 Kudos

Hi,

when I'm trying to get the debugging session for amdp-procedure, I get the same message "Source not found" when debugger stops. Did someone solve this problem?

0 Kudos

Hi, is the ABAP class contained in the lookup path; when it is working it looks like:

0 Kudos

Thanx for a fast reply. I've tried to choose a classname folder from a workspace with a similar directory path, but after choosing a directory window with a message "Source not found" for a second filled with code of a method, but on the next second window become the same as before - "Source not found". May be I need to do something else in eclipse client or in HDB system?

Best regards,

Dmitry

0 Kudos

For me this looks like a bug which is fixed in more recent versions of ADT (and the manual adjustment would just be a workaround).

0 Kudos

Hey Dmitry,

are you talking about external session debugging (in HANA) of the database procedure corresponding to an AMDP? Depending on the ABAP version, you might as well debug it directly in the ABAP (please post your SAP_BASIS release and the HANA release). Assuming you have something lower than ABAP 7.4 SP8 (and HANA below SPS8), you can only debug it with the "external session debugging" procedure.

I have two possible explanations for your issue:

1. You might lack authorizations (did you follow the procedure explained in )

2. As Christian mentioned, it might be an issue with your HANA Studio? From your screenshot I cannot see whether you are using a HANA Studio or an Eclipse installation with the SAP Developer Tools in Eclipse. Please use the latter one, i.e. follow the procedure explained on http://tools.hana.ondemand.com (preferentially based on Eclipse Luna) and install the HANA and ABAP plugins.

Cheers,

  Jasmin

0 Kudos

I was not able to solve it, but turns out that in my case I could ignore the message since the debugger was running normally in another tab within the interface. If your situation is the same as mine then just look for the debug session in anther tab and you should find it waiting for you.

0 Kudos

Thanx for your advices, but the only thing that helped me with this is the reinstalling the eclipse. After reinstalling client from kepler to luna - debugger works fine! Thanx for that!

But now after re-installation I'm getting the message for reset Perspective after any changing the perspective view of Eclipse. Did you see it before?

When I intalled new version of Eclipse I installed software from tools.hana.ondemand.com/luna, kepler and juno. May it be a reason for a such message at any changing of a perspective?