Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Debugger Problem: Full data is not displayed in the fields of the ITAB

manoj_goyal2
Participant
0 Kudos

Hi Guys,

I am having a problem related to ABAP Debugger. Data is not fully displayed in all the field of the internal table. I am using SAPGUI 640 with ECC6. In the debugger I have increased the width (size) of the column but still data is not fully displayed.

Below is the example:

*Actual Data*        *Displayed As*
1141               11...
P42X13             P...
Testing            Tes...

When I bring the curson on the displayed incomplete data, the full data is shown in small popup window.

I have increase the size of the column but still it is not showing the complete data.

I have to download the internal table data to an excel spreadsheet to view the complete data.

Please help.

Thanks,

mini

7 REPLIES 7

Former Member
0 Kudos

Maybe you should ugrade to a new SAPGui version (e.g. 710).

As far as I remember, the first 'new debugger' was a mixture of the old and the new one with a lot of bugs.

Which patch level do you have in your SAPGui (right-click in taskbar -> 'About SAP logon').

0 Kudos

I cannot use SAPGUI 710 as my company is not upgrading it to 710. We have to live with 640 for now.

SAPGUI details are as follows:


Name............: saplgpad.exe 
Description.....: SAP Logon Pad for Windows
Product version.: 640 Final Release
File version....: 6405.5.21.1020
Build number....: 855417

Please help if you can. This is very frustrating.

Thanks.

former_member181995
Active Contributor
0 Kudos

Mini,

please broad that perticuler column by picking its right wall with mouse.

Amit.

0 Kudos

Hi Amit,.

In my first post, I told that increasing the size does not help. After broadening the column, full data is still not displayed.

Thanks,

Former Member
0 Kudos

Hi Mini

Check if you have sufficient authorisation

0 Kudos

Hi Sriram,

Can you please tell he how I can check the authorizations.

I am an ABAPer.

Thanks,

manoj_goyal2
Participant
0 Kudos

Hi Guys,

I think the problem is related to Exclusive/Non-exclusive debugging sessions. The debugger session is in Non Exclusive and that's why the data is not fully displayed. Can you tell me how I can user EXCLUSIVE debugging sessions.

Thanks.