Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
Showing results for 
Search instead for 
Did you mean: 

database table doesnt exist

Active Participant
0 Kudos

Hi to all,

we had created a Ztable and transported to production. After that we had changed the length of some fields and activate and transported to quality , But in quality its showing error message like

u201Czxxx is locked because a restart log exists.u201D (I donu2019t know what does this means)

After this when I press enter I get this message in a message box.

u201Ctable zxxx does not exit in the database�. But still Iu2019m seen all the fields on table zxxx.

Iu2019ve tried Database Utilities through Utility it took a while but then I get short dum error.

Now when I go to Database Utilities it shows me 2 buttons.

CONTINUE ADJUSTMENT (with execute icon)

UNLOCK table (With red corss icon).


Active Contributor
0 Kudos

I think your Basis team has scheduled 'database restart' at the time transport moved to quality system..please check with them..

Active Participant
0 Kudos

check below link might be helpfull for u.


0 Kudos

First check in development system table is working properly or not...

if its wrking properly there in development system delete table maintainanace generator and delete once more and save the TR..

transport this TR... Make sure that all the component of table is stored in same TR

Former Member
0 Kudos

Hi friend,

You are able to see the table but you are getting the message that "Table doesn't exist in database" means the table is not activated in the database. Its just in a temporary memory.

So you try the option "Adjust and activate " and see. If you still get the same then you need to re transport the table again.

I think this will solve your issue. If you still face any queries please revert back to me i will help you.


Sri Hari

Active Contributor
0 Kudos

When you transported you new table to QAS, SAP has started conversion process to convert strcuture and store data in this new structure of your table. SAP starts the conversion process by putting a lock on table. And at the end of successfull conversion, lock is removed.

If conversion process fails (there could be number of reasons) lock remain there. This prevents any further changes to structure without fixing the problem.

I would suggest look at object log (in database utility) and see what went wrong during conversion.



Edited by: pawankesari on Jan 31, 2012 3:09 PM

Former Member
0 Kudos

Hi Geetha,

I would advise you to kindly please gothrough this note 1248769. Also kindly please check in se11is the data dictionary exist. If it is exist I would advise you to kindly please active the table in se11 and it will create the table in the database automatically.

Many thanks.

M W Hussain.

Former Member
0 Kudos

Hello Geetha,

There could be many reason for this; one is explained by pawankesari, other is that while SAP was doing the adjustment some process or user might have placed a lock on the table. That is why the transport related to table structure adjustment should be done at a time when the process or users are not active.

Anyways your table data is not lost. It is just stored in a $tmp table. If you go to SE11 and then via menu: utilities->run time object->Check then you will that it says something about inconsistency.

All that you need to do is: SE14->Edit

The select "background" and "Save Data" radio button and then press "Activate and adjust database" and your table will be restored.

Let me know if you tried this and if it worked for you.