Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
Showing results for 
Search instead for 
Did you mean: 

Can't print all reports in SAP - Error Occured (message PT118)

0 Kudos

Hi ABAPers,

I find an issue when one user in my place can't print all reports in SAP. I have checked the authorization and it seem that this user has all authorization he needs.

I check if it is external problem, PC problem, but it's not. He can print from any other application in his PC (ms word, excel, notepad, etc). He can't print in SAP only. We also have tried to change the PC to other PC but still can't print SAP reports. It means it's not a problem with his PC / printer.

I check parameters of printer in SU01 and find that he has all parameters same with me, then it shouldn't be a problem.

Then I track the error message PT118 - Error Occured. I find this error will be raised if Archieving Type doesn't have value '1', '2', '3' or blank. So I guess that the problem is on here. But I didn't know where to set this archieving type parameter. It is not parameters in SU01.

Could any body give me clue, what should I do to resolve this problem. I try to find in the forum but can't find any solution.

Thanks alot




0 Kudos


Did you check the spool? I'm afraid it's just a matter of print immediately or not.

0 Kudos

Yes Samanta, I have.

Actually the error keep prompt up everytime the user press print button. So it never print or go to spool at all.




0 Kudos

Hi Everybody I've solved this issue creating a specific role with authorization object S_SPO_ACT value PRNT, in SPOACTION field.

I hope you will find this information useful.

Best Regards.