Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Batch input error in background mode (mode N)

Former Member
0 Kudos

Hi,

I encounter a problem with my program, it must simulate the transaction IW31 with a batch input

but when I run it in the background (mode N) i receive an error :

"Data do not exist for the batchinput DYNPRO SAPLCOIH 0100"

in foreground (mode A or E) => success

Does anyone have an idea of the origin of the problem?

Thx, for your help.

Christophe

ps : sorry for my english

4 REPLIES 4

Former Member
0 Kudos

Are you entering long text ? what is the ok-code for long text ? TXBA ?

Sandra_Rossi
Active Contributor
0 Kudos

There are several possibilities, see this wiki : [BDC - FAQ - Why a transaction called via BDC behaves differently?|http://wiki.sdn.sap.com/wiki/display/ABAP/BDC#BDC-WhyatransactioncalledviaBDCbehavesdifferently%3F]

According to this wiki, and what you describe, the cause can be:

1) SY-BATCH is tested by the program -> You may try to do a new recording using "simulate background mode".

2) Authorization check -> Make sure the user is the same

3) Date or number format -> Make sure the user formats and parameters are the same

4) The BDC stops before the end -> BI sessions do not allow to continue the BDC after a COMMIT WORK, but you may call the BI session by converting it into CTU using RSBDCCTU. You have to enter its Queue ID (you see it in SM35).

5) GET CURSOR statement -> Make sure BDC_CURSOR is filled for all screens

Former Member
0 Kudos

hi,

thx for your answers.

I searched in the BDC - FAQ but i not found the solution.

also i rewrite my program in using :

1 - module function for create the order : ALM_ME_ORDER_CREATE

2 - module function for savethe order : CO_ZV_ORDER_POST

3 - Batch Input for simulate transaction IW32 for launch the order

I don't know if it 's a good pratice with this solution but it works

Good day.

Christophe

0 Kudos

You didn't have to search that wiki, I had done it for you and told you what you should have found in it, see my previous post.

Anyway, that's cool you solved the issue.

I forgot to say: welcome to SDN. Please read the forum rules before posting again.