Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

ALV Report

0 Kudos
89

Dear sir,

I have ztode named with 'ZFBL1N'. it is retrived from standad tcode 'FBL1N'

it is a alv report

when i am try to change the layout in the output list

it is going to standard prg's include

so that 1 itab(it_specfld) is not retriving data

this is the problem . please suggest me

Thanking you,

sudhakar

6 REPLIES 6

Former Member
0 Kudos
54

may be that call to this perform will be like this

perform display_alv ( std.program ) .

check this ?

Regards

Peram

0 Kudos
54

hi,

yes the alv part of the code is in RFITEM_INC.

i copied that include into my z include named ZRFITEM_INC_01 in that it's having 1 subroutine 'form analyze_act_fieldcat' .for the basic list it is working properly giving data correctly. after getting basic list i am trying to include new fields into that list. it is working for few fields good , but some fields going to display some warning message 'error with subroutine 'analyze_act_fieldcat' .in debugging i observed that it is going to standard prg and include RFITEM_INC so that itabs 'it_spectab' and 'it_specfld' r not getting data i.e it is showing error msg.

plz tell me why it is going to standard prg.

Regards,

sudhakar.

Former Member
0 Kudos
54

Hi,

The alv part of the standard program is in the include program name-- <u><b>RFITEM_INC.</b></u>

Make a z copy of this standard include and change there,

Hope yoyr problem will be solved.

If not the post part of your code

<i><b>Reward point for helpful answer

Debjani Lahiri</b></i>

0 Kudos
54

hi,

yes the alv part of the code is in RFITEM_INC.

i copied that include into my z include named ZRFITEM_INC_01 in that it's having 1 subroutine 'form analyze_act_fieldcat' .for the basic list it is working properly giving data correctly. after getting basic list i am trying to include new fields into that list. it is working for few fields good , but some fields going to display some warning message 'error with subroutine 'analyze_act_fieldcat' .in debugging i observed that it is going to standard prg and include RFITEM_INC so that itabs 'it_spectab' and 'it_specfld' r not getting data i.e it is showing error msg.

plz tell me why it is going to standard prg.

Regards,

sudhakar.

Former Member
0 Kudos
54

Hi,

What you can do is copy that include to a ZINCLUDE, and declare all the variables and internal tables used in that include to your ZPROGRAM, and try to call this subroutine(i.e. One in your ZINCLUDE) and make changes accordingly.

Hope this helps.

Regards,

Raghavendra

0 Kudos
54

hi,

yes the alv part of the code is in RFITEM_INC.

i copied that include into my z include named ZRFITEM_INC_01 in that it's having 1 subroutine 'form analyze_act_fieldcat' .for the basic list it is working properly giving data correctly. after getting basic list i am trying to include new fields into that list. it is working for few fields good , but some fields going to display some warning message 'error with subroutine 'analyze_act_fieldcat' .in debugging i observed that it is going to standard prg and include RFITEM_INC so that itabs 'it_spectab' and 'it_specfld' r not getting data i.e it is showing error msg.

plz tell me why it is going to standard prg.

Regards,

sudhakar.