Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

ALV CellTab issue

Former Member
0 Kudos
288

Hello Friends,

I strucked in ALV Container problem. Not able to figure it out. Please help me to fix this issue.

My requirement is as follows

I took one container using OO programing to display ALV fields. This is editable screen.

My requirement is I have 6 fields in ALV with 10 rows, In 10 rows, first 2 fields always are enabled mode. Once user entered data in 2nd field, remaining 4 fields should be either enabled/disabled depending upon my logic. I am using CELLTAB and er_data_changed in my 2nd field logic. I am able to enable/disable fields for 1st row. Supponse 3,4,5,6 fields are enabled mode and making change in GT_OUTPUT internal table. it works fine

When I goto 2nd row, my celltab is going empty for 1st row, so 1st row 3,4,5,6 fields are now in disabled mode.

My CELLTABL declarition is wlt_celltab TYPE lvc_t_styl.

My question is once I modify my CELLTAB in GT_OUTPUT internal table for 1st row, why GT_OUTPUT-CELLTAB contains 0 values.

Please respond with your answers.

1 REPLY 1

former_member314455
Participant
0 Kudos
70

Hello Sree,

Write code like this -

wlt_celltab should contain fields which have to be modified in the runtime. Insert wlt_celltab INTO TABLE GT_OUTPUT-CELLTAB.

After that call method refresh_table_display of your ALV class.

Regards,

Ajith