Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

#ABAP_Trial AS ABAP 7.52 SP01, developer edition on OpenSuse Leap 15.1 as a VirtualBox guest

Hello

I'm trying to install SAP Netweaver AS 7.52 SP01 on a VirtualBox guest virtual machine with openSUSE Leap 15.01 following the tutorials by julie.plummer but always ends on the same error.

I installed the openSUSE with Gnome, as a server without graphic desktop; with the network configured on VirtualBox as NAT, or as bridge network.

I tried to install it on openSUSE Leap 15.1, on openSUSE Leap 42.3 (now obsolete, but used by Julie on the tutorials), on Ubuntu 18.04 too.

I tried to install with the files on a shared folder between my computer host, and the virtual guest. With the files copied on the virtual machine disk.

I'm now on the 8th try. The sapinstall always ends with same error.

I uploaded all the steeps followed as screenshots to imgur:

AS ABAP 7.52 SP01, developer edition on OpenSuse Leap 15.1 as a VirtualBox guest

I uploaded the install log and the sapinst_dev.log to my Dropbox's Public folder.

I don't known what I'm doing wrong.

I need guidance to solve this.

Thanks in advance.

5 REPLIES 5

Jelena
Active Contributor
0 Kudos

What exactly is the error?

0 Kudos

Hello
It appears to be a login error with the newly created user for database.

UweFetzer_se38
Active Contributor

I've got two possible reasons in my mind:

- please check, if the hostname is "vhcalnplci" and is not overwritten by DHCP
- maybe the ASE license has expired

Both errors are described here: https://blogs.sap.com/2018/10/16/sap-as-abap-7.5x-developer-editions-faqs/#error_install

julieplummer20
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Adrian,

Definitely check as Uwe said: DHCP must be set to "No" (see FAQs, though it is also in the latest Newbie Guide for VMWare).

And check your license.

If that fails, I am sorry, but it the error would beyond the scope of this forum. You can check the error yourself as follows:

1. Look for error in the sapinst_dev.log . You will see an error referring to "Can't open a connection to site 'SYB_BACKUP' . Also, an error like " Assertion failed: Unable to verify database access for login SAPSR3. ". Therefore, these point to an issue with the database.

2. You could post the error to the SAP Community Sybase ASE forum .

3. The expert page, including the docu links is here: SAP Community: SAP ASE

Otherwise, you seem to have hit on a very rare error. I have never seen the first of these before.

If you don't want to dive too deeply into ASE DB support / config just yet, there is a Docker option, also in the FAQs.

I hope one of these helps.

Small tip for future reference: Could you please post the ERROR statements from the log files, not the whole 8 MB - it's more secure, for you and me.

Best wishes,

Thanks to both jelena.perfiljeva , jelena.perfiljeva2 2 (!), and se38 .

Julie.

kaus19d
Active Contributor
0 Kudos

Hi,

My suggestion here is to check the database ENV values. Check the required database mount points are available. If the dummy.nodomain domain is not pingable, i mean, you already mentioned that its a trial system, which would mean that the database & application is on the same host probably, so you can remove the dummy.nodomain from /etc/hosts & proceed with "Local System" option during installation as is suggested by Julie in above.

If Sybase DB initial install is already done, then please check the below commands

su - syb<SID>

dba

sp_help

If Sybase-DB is installed, then next to check is /sapmnt/<SID>/profile/DEFAULT.PFL if the SAPSR3 is added in parameter value

Also please check the "ifconfig" & "ip a" if the ip details are actually coming

You can try the above & let us know the outcome & we can assist further

Thanks,

Kaushik