Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
Showing results for 
Search instead for 
Did you mean: 

ABAP Eclipse - No assertion ticket error

Former Member
0 Kudos


I am getting the following error in the Eclipse environment while connecting to the backend SAP system.

"The system did not return an assertion ticket for the GUI logon. Continue logon manually".

Eclipse detailed error log says "Could not get reentrance ticket for GUI logon: No authorization to access the resource  /sap/bc/adt/security/reentranceticket".

Plz help me out in fixing this problem.




Active Contributor
0 Kudos


Have checked with roles, authorizations and profile parameter are configured properly for your user ?

Refer to installation guide of ADT attached to this note: 1718399

It says following:

In addition to logon tickets, ABAP systems can also issue the more restricted assertion

tickets when accessing system services. This might be important to meet the maximium of

security requirements when using the integrated SAP GUI in APAP Development Tools.

Instead of asking the password, the back-end system checks the validity of assertion ticket

to allow the user access to system services.



Use the following settings to configure your ABAP system in such a way that it issues the

assertion tickets only (without logon).

Profile Parameters

Parameter: login/create_sso2_ticket

Value: 3

Description: The parameter with this value causes the ABAP system issues assertion tickets only (no logon tickets).

Parameter: login/accept_sso2_ticket

Value: 1

Description: The parameter with this value configures the ABAP system to accept assertion tickets.


Ashwani Kr Sharma

0 Kudos

Hi Ashwani,

Thanks for your quick response.

Following roles has already been assigned to my Id (as mentioned in the ADT installation guide). 



I didn't check the profile parameter settings but I am sure they must be in place since another user (who has SAP ALL access) is able to login in without any error (he is also conneting to the same backend SAP system). And when I asked him to check if he is able to login with my ID in his machine, he responded back saying he is also getting the same error. So looks like some authorizations are missing in my user profile.



0 Kudos


Perhaps you need to maintain a few authorizations like in this discussion ( You should also be aware of the caveat discussed here ( when maintaining authorizations.



Active Contributor
0 Kudos

Well, I think is never too late to solve this.

I had this same issue and it was solved doing the following:

  1. Go to transaction RZ11
  2. Change profile parameter login/create_sso2_ticket to "2" (I was set to zero when the error was happening) - Moreover there is no option 3 according to the profile documentation
  3. Click on "New Entry" to make this value permanent.