Showing results for 
Search instead for 
Did you mean: 

WSAEWOULDBLOCK when logging into SAP via VPN

0 Kudos


When trying to log in to SAP via a VPN, I get the error:

partner '10.x.x.x:sapdp02' not reached

WSAEWOULDBLOCK: Resource temporarily unavailable

I feel that I read almost all the other posts on SCN but still I can't find an answer.

Here is what I can tell you, and what I've tried so far.  Any other suggestions?

The SAP server is up.

We've tried connecting with the same credentials from a different machine and it works.  Thus the problem is either with my network or my PC.

I've been able to login to that server before from my PC succesfully.

I cannot ping the server.

I cannot open a telnet session to 10.x.x.x 3402, nor on port 3602.

I've tried to connect with different network setups: 3G, wireless, cable - all give the same result.

I've disabled my local firewall and antivirus.

What else can I try?

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi Andre,

Is you VPN connection stable on this PC.  Is it the same VPN version installed on the other PC's.  You could try uninstalling and re-installing the VPN client.

Can you check your services file on the PC having the issue and ensure  sapdp02 3402/tcp, sapgw02 3402/tcp, and sapms<SID> 3602/tcp.  It sounds like and issue between this services file and your saplogon.ini.  Try swapping out both the services and saplogon.ini from a machine that is working.


Dan Mead

0 Kudos

Thanks Daniel

I found the solution - it was outside any expected cause.

I've installed Xamarin, and apparently it influenced certain ports or something.  Uninstalling Xamarin solved the problem.

Thanks for you response.