Showing results for 
Search instead for 
Did you mean: 

unable to set the network configuration after error no startprofiles found.

Former Member
0 Kudos


Got the NW4 test drive set up/installed on suse linux 10.2.when i logged in and try to start the system (i use 'start nw4host') i get the error 'no start profiles found'.i understood that network interface had to be set up and this is where am confused and lost.

1. In /etc/sysconfig/network there was no ifcfg-eth file bt default in first place only a ifcfg-inet:0 file.

2.ifconfig -a does not give me my mac address in linux

since mine is a dual boot system found my mac address from XP and created the ifcfg-eth-id-<mac adress> file and changed the DEVICE to eth0:0 instead of inet:0 as in the previous file(ifcfg-inet-0 file).

3.other parameters in the ifcfg file are fine(onboot, IP, etc...)

4. /etc/hosts has nw4host and same was in old ifcfg-inet-0 file and the new file i created(ifcfg-eth-id-<mac adress>) nw4host is present thrice in /etc/host file one below the other and also three sets of same values in ifcfg-inet and ifcfg-eth-id-<mac>? dont know why and if this is the problem.

finally did a 'rsnetwork restart' after changes and still getting some interfaces failed in the output and nw4host is still not pingable.

any ideas suggestions of whats wrong and how it can be set right ? its been quite some time after install and i would love to get my testdrive going.

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Kamal , Tamilboy Thanks for the interest and response.I have tried this and it does not seem to work.

should the the HWaddr mentioned in /etc/sysconfig/network/ifcfg-eth-id-XX:XX:... be same as XX:XX:... mentioned in the file name and the actual MAC address of the network card( can a dummy mac address be mentioned in the file name part and inside that) ??

if so ..any suggestions for Dummy MAC address?

How can i find the MAC address from linux terminal ? right now i find it out from XP 'ipconfig all' ?

think my network card is not detected at all ? can i check or trouble shoot this in a certain fashion in linux ?

Is this particular interface in linux equivalent to the microsoft loopback adapter which needs to be installed in XP side for getting the testdrive running on XP right?

can somebody kindly confirm/suggest if these are the actual steps involved for getting the interface up.

a.create ifcfg-eth-id-xx:yy:zz under /etc/sysconfig/network

b.following entries in it



IPADDR='' - same as in /etc/hosts


DEVICE=eth0:0 rcnetwork start

d.check ifconfig -a for the interface and ip address.

Awaiting your views and suggestions on this..before am forced to do a wipe out and re install...

Thanks in Advanca


Active Contributor
0 Kudos

If no MAC addresse is found then your network card is not detected.

Check with

dmesg | grep eth0

If you don't get something, there's no network driver for your card and thus the system can't get a MAC addresse.

Former Member
0 Kudos

Hi Gnana Kandasamii,

Try to set the network from GUI (Graphical Interface)

neet or system-config-network are the command to set network.

If you are using dell server than kindly check the bios setting might be your network is disabled from there. also check the network details from /etc/sysconfig/hwconf file. you can create the following file also if required









also check the networking=yes as follows

cat /etc/sysconfig/network




Thansk and Regards,

Kamal Kishore

Former Member
0 Kudos

Check this note

Note 722273 - Red Hat Enterprise Linux 3 and 4: Installation and upgrade

Even though this note is for RedHat, check the part where it talks about /etc/hosts/ and network files. This might help you.