cancel
Showing results for 
Search instead for 
Did you mean: 

SAPGUI Attach creats his own RFC- Destination; eCATT

Former Member
0 Kudos

eCATT 6.4

Hello,

i've a problem:

SAPGUI Attach creats his own RFC-Destinations and I don't know why. I was scripting a case and wanted change some things. But the problem is that the script doesn't use my RFC Connection from the scripting. It creats his own RFC Connection (I can see it in SM59) and tries to connect our system with wrong entries. The connection failed and I can't use SAPGUI Attach and change the script.

Can anybody help?

Best regards

Dirk

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

Congratulations, you found a bug

This is simple to fix - delete the generated destination from the SAPGUI command and replace it either with a destination of your own from the system data container or, if you want to use system that is defined as the default system for the entire script, don't specify a destination at all.

Former Member
0 Kudos

Hello Jonathan,

it sounds so easy but...

I tried to replace the generated destination from the SAPGUI command with a destination of my own, but it doesn't work. I can't the generated destination delete or replace. I can only change the settings of the generated destination, what I did.

But until now I get only error messages in the logs:

"Some screenings are missing" after the restart of the attached scripting.

I'm not sure, whether the problem with the destination is resolved or, whether this new error message is a part of

the destination problem.

My question is, can I replace the destination in the SAPGUI command or do I have to change the settings in this generated destination?

Best regards

Dirk

Message was edited by: Dirk Raschke

Former Member
0 Kudos

Hi Dirk,

You only have to change the destination in the SAPGUI command. Here is an example:

SAPGUI ( VA33_100_STEP_1 , ECATT_SAP_QAT_093_E ).

Just remove the ECATT_SAP_QAT_03_E part of the command and replace it with the name of your RFC destination from the System Data Container. Just as an example, the name of my RFC destination is RTEST so my new command would look like this:

SAPGUI ( VA33_100_STEP_1 , RTEST ).

According to Jon's last post, you could just delete the eCATT generated destination completely from the command so that the default destination specified in the attributes tab is used. If you decided to do that your command might look something like:

SAPGUI ( VA33_100_STEP_1 ).

This would be a more desireable method because if you decided later to change the destination of all your commands to RTEST1 you could simply change it in one place (the attributes tab) rather than changing the destination in each command.

The most important thing is that all your commands are consistent. In other words make sure they all have the same destination, session number and connection number. If one of the commands is different you will start running into problems.

Message was edited by: Ben Weisberg

Former Member
0 Kudos

Hi Ben, hi Jonathan

Ok, I hope I've got it right now.

I tried the changing in the column "target system" of the command interface, because there is it possible to click through the target destinations and I thought I could replace my destination on this point.

Now I'll try your example.

with best thanks

dirk

Former Member
0 Kudos

ok, thanks.

the problem seems to be solved.

I changed it in the command editor...

the other problem was, I didn't realise that the connectionid and the sessionid wasn't equal.

I read this (checking the IDs) so often before .....

thanks for your help,