cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with Plugin Installation of SAP widget Developement tool in Eclipse

Former Member
0 Kudos

Dear All

I am faceing problem while installation of SAP widget Developement tools in Eclipse. Please help me Out.

I have Downloaded Eclipse and also SAP Widget Developement tools.zip

When I try to Install the Plugin for SAP Widget developement I get an error saying "Install has encountered a problem.Cannot Complete the install because one or more required items could not be found". When I click on Detail to see teh details following error log is displayed :

+Cannot complete the install because one or more required items could not be found.

Software currently installed: SAP Widget Development Tools 0.13.0.1376 (corp.sap.pal.gadgets.tools.widgetTools.feature.group 0.13.0.1376)

Missing requirement: Structured Source JavaScript Model 1.0.101.v200706071955 (org.eclipse.wst.javascript.core 1.0.101.v200706071955) requires 'bundle com.ibm.icu [3.4.4,4.0.0)' but it could not be found

Cannot satisfy dependency:

From: SAP Widget UI Designer 0.13.0.1376 (corp.sap.pal.gadgets.tools.uidesigner 0.13.0.1376)

To: bundle org.eclipse.wst.javascript.core 0.0.0

Cannot satisfy dependency:

From: SAP Widget UI Designer 0.13.0.1376 (corp.sap.pal.gadgets.tools.uidesigner.feature.group 0.13.0.1376)

To: corp.sap.pal.gadgets.tools.uidesigner [0.13.0.1376]

Cannot satisfy dependency:

From: SAP Widget Development Tools 0.13.0.1376 (corp.sap.pal.gadgets.tools.widgetTools.feature.group 0.13.0.1376)

To: corp.sap.pal.gadgets.tools.uidesigner.feature.group [0.13.0.1376]+

I require your help in this .

Regards,

Nikhil

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Nikhil,

Looks like some problem in the eclipse version.

Refer to the last point in this link - [; which says -

"The newest and default version of Eclipse is Galileo which is version 3.5.x

According to the Widget development guide, widget developer tool covers Eclipse 3.3.x (Europa) and 3.4.x (Galileo).

The problem is solved by downloading one of those versions from http://wiki.eclipse.org/Older_Versions_Of_Eclipse and installing widget development tools."

Hope this helps.

Regards,

Shilpa B.V

Former Member
0 Kudos

Thanks Shilpa. I already had sorted out this issue.

Thanks for your response.

Regards,

Nikhil

Former Member
0 Kudos

Can you help me with the SAP widget Development tool zip file, my zip folder doesnt have all required files.

former_member199126
Participant
0 Kudos

hi nikhil , I even have the same problem , Can u help me in sorting out the issue ? It will be of great help if you tell me the steps that you have followed in installing the widget development tools ...What kind of eclipse version did u use for that ... ??

Answers (0)