cancel
Showing results for 
Search instead for 
Did you mean: 

GUI error "service 'sapdp01' unknown"

former_member185943
Participant
0 Kudos

Hello!

User can't logon to SAP from his workstation. When he preses the Logon button from his SAPlogon, he immediately gets an error message "service 'sapdp01' unknown" (no logon screen). On other workstations everything works normal.

It might be a coincidence, but this happens since user installed "CloneCD" application. I removed it and reinstalled SAP gui (several times, with PC restart), but the problem persists.

The file "<windir>/system32/drivers/etc/services" contains the line "sapdp01 3201/tcp" as it should and all other sapdpXX lines up to 99.

Is there any solution except disk formatting?

Thanks!

Kind regards,

Igor Barbaric

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Not sure what the root cause is but you can use a tool like "filemon" from Systinternals to verify which services files is being accessed by the saplogon process...

former_member185943
Participant
0 Kudos

Hello, Somckit!

This tiny utility that you guided me to showed that user's GUI wasn't actually opening the file C:\WINDOWS\system32\drivers\etc\services, but rather C:\WINDOWS\nsdb\services, which didn't exist on the PC.

I copied C:\WINDOWS\system32\drivers\etc\services to C:\WINDOWS\nsdb\services and now it works fine.

The questions which stay unanswered are:

- Why is GUI trying to open the services file on another location?

- Why this wasn't corrected by GUI reinstall?

- Why none of other PCs behave like this and don't even have the C:\WINDOWS\nsdb folder?

But, the most important is that the main prboblem was solved.

Thanks for this hint!

Kind regards,

Igor Barbaric

Answers (5)

Answers (5)

Former Member
0 Kudos

Awesome work for this one......I started poking through the registry, and thankfully I was looking at this note to find a solution.

Thankso

Former Member
0 Kudos

Hi All,

Can anyone help ? My users are facing the same problem as well. I had changed the registry entry: Databasepath to C:\WIndows\System32\Drivers\Etc instead of

%SystemRoot%\System32\drivers\etc and the users were able to login but after 1 or 2 weeks they can't login as well, even after changing the registry entry again.

Can anyone help ? Is there a permanet solution to the problem ? Is MSN Messenger 7.5 the cause of the problem ?

Please help.

Thank you

Christian_Cohrs
Advisor
Advisor
0 Kudos

Hi,

as mentioned in the other thread, please have a look at note 882741 and let us know if the problem persists.

Best regards,

Christian

SAP Note No. 882741 29.09.2005 Page 1

________________________________________________________________________

Number 882741

Version 10 from 26.09.2005

Status Released for Customer

Set on 26.09.2005

Language EN

Master language EN

Short text SAP Logon: Logon balancing error, service 'sap...'

unknown

Responsible

Component BC-FES-GUI

Graphical User Interface

________________________________________________________________________

Long text

Symptom

Some users cannot longer connect SAP GUI to any SAP systems e.g. via SAP

Logon, SAPShortcut etc. although they have not made any update to either

SAP GUI or SAP system. The attempt to connect to the SAP system ends

with error messages like this: "Logon balancing error: could not

connect to message server (rc=9)", "service sapmsXXX unknown" or

"service sapdp## unknown".

The detailed error information is as follows:

Error: service 'sap...' unknown

...

Component NI (network interface), ...

rc = -3, module ninti.c, line 463

Detail NiPGetServByName: service 'sap...' not found

System Call getservbyname

Other terms

service sapmsXXX unknown,logon balancing,service sapdp## not found

error,etc/services,drivers\etc\services,getservbyname, sapdpxx

MSN Messenger 7.5,Connection Troubleshooter

Reason and Prerequisites

The reason for this malfunction is, that the datatype of the registry

value

HKLM\System\CurrentControlSet\Services\TCPIP\Parameters\DatabasePath

was changed from REG_EXPAND_SZ to REG_SZ.

The following programs are currently known to cause this registry

change:

- Starting MSN Messenger 7.5 "Connection Troubleshooter" (Build

7.5.0299).

- Installation of MSN Messenger 7.0 or MSN Messenger 7.5 with

the option automatic scanning and configuration of ports.

This modification prevents the expansion of environment variables in the

value of the parameter. Therefore,

%SystemRoot%\system32\drivers\etc

is not translated to

c:\windows\system32\drivers\etc

and the services database is not found by the API function

Page 2

getservbyname().

If you have checked the datatype of registry value DatabasePath and it

is REG_EXPAND_SZ, apply SAP Note 52959 to check the appropriate settings

in the services file.

Solution

Start the registry editor and rename the registry value

HKLM\System\CurrentControlSet\Services\TCPIP\Parameters\DatabasePath

Create an Expandable-String Value (REG_EXPAND_SZ) with the same name and

value.

If more PCs are affected, you can export the correct value to a .reg

file and import the .reg to other PCs.

If you have the same problem although you have not installed Microsoft

MSN Messenger 7.5, create a customer message, collect the following

information and attach it to the message according to note 541726 or

upload it to sapservX (see note 40024):

o Scan your workstations for spyware and viruses with up-to-date

virus definitions. If you already did that what was the result ?

o What software has been installed recently ? (client software,

Firewall)

Create a registry export of the following key

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Unin

stall

on the affected and the unaffected PC respectively and attach the

two .reg files to the customer message.

o Are the users on the affected workstations logged on with

administrative credentials (local administrator ) ?

o Create an MPS Report Networking and Setup Perf of an affected

workstation so that we can check if they use an software in

common.

You can download the Networking MPS Reporting Tool at:

http://download.microsoft.com/download/b/b/1/bb139fcb-4aac-4fe5-

a579-30b0bd915706/MPSRPT_Network.exe

You can find a short description about the features of the tool

at:

http://download.microsoft.com/download/b/b/1/bb139fcb-4aac-4fe5-

a579-30b0bd915706/MPSRPT_Network_Readme.txt

The Setup Perf MPS Reporting Tool is located at:

http://download.microsoft.com/download/b/b/1/bb139fcb-4aac-4fe5-

a579-30b0bd915706/MPSRPT_SETUPPerf.EXE

Run this report too on identically configured workstations, which

are not affected.

Page 3

If you have already changed back the DatabasePath parameter and if after

a while the value was switched back to REG_SZ perform the following

steps to help us to identify the reason for this problem:

o Switch the datatype back to REG_EXPAND_SZ

o Download Regmon from http://www.sysinternals.com on the affected

machines

o Enable auditing on the affected clients

o Modify the settings of the eventlog so that no important entry is

deleted!

Open Regedit and highlight

HKLM\System\CCS\Services\TCPIP\Parameters

Right-click on "Parameters" and choos "Permissions" and click

"Advanced".

Choose "Auditing" and "Add".

Add "Everyone" and select "this key only" under "Apply onto".

Check the boxes "Set Value" and "Delete" and click "OK".

Apply these settings

o Start Regmon and apply the correct filter settings:

Press the "magnifying glass" button to stop the monitoring.

Press the rubber button to delete all logged entries.

Go to "Options Filter/Highlight".

Copy the following value to the include field:

tcpip\parameters\databasepath and click "Apply".

Start Regmon by pressing the magnifying glass button

o Verify that logging starts when you double-click the TCPIP Key in

regedit!

If the datatype will be changed again, provide us the output of the

monitoring tools.

________________________________________________________________________

Note is release independent

Further components

BC-OP-NT

Windows NT

________________________________________________________________________

Reference to related Notes

Number Short text

____________________________________________________________

52959 sapms..., sapdp.., sapgw.. unknown (or not found)

________________________________________________________________________

Former Member
0 Kudos

everybody met this problem can also refer to:

Former Member
0 Kudos

Hello,

I had the same problem, but now it has been solved.

I got the following registry keys/values:

1. \HKLM\SYSTEM\ControlSet001\Services\Tcpip\Parameters\DataBasePath

2. \HKLM\SYSTEM\ControlSet002\Services\Tcpip\Parameters\DataBasePath

3. \HKLM\SYSTEM\ControlSet003\Services\Tcpip\Parameters\DataBasePath

4.\HKLM\SYSTEM\CurrentControlSet

\Services\Tcpip\Parameters\DataBasePath

= %SystemRoot%\nsdb

I changed the registry entries values to

%SystemRoot%\system32\drivers\etc

then executed SAPGUI and it worked perfectly.

I think that the cause of the modification of this registry entry was a virus.

Kind regards

Christian_Cohrs
Advisor
Advisor
0 Kudos

Hi Alvaro,

I think you you may be right! According to http://securityresponse.symantec.com/avcenter/venc/data/pf/adware.tmksoft.xplugin.html this could be an Adware application named XPlugin XFilter.

Best regards,

Christian

Former Member
0 Kudos

Hey,

I'm glad that helped I was thinking that was the issue...

I would suspect some registry entries didn't get cleaned up? Maybe run sapsweep?

Former Member
0 Kudos

Hello,

we're having the same problem and have tried out the proposed solution with FileMon but SAP is pointing to the correct directory, but cannot find the Services file, although it's there (and it's correct). We've tried to re-install several times, ran sapsweep and re-installed again, but we still have the same problem.

Any suggestions?

Many thanks!

Candy

Christian_Cohrs
Advisor
Advisor
0 Kudos

Hi Candy,

does filemon report an error when SAP GUI accesses the services file? Maybe it's a problem with the access rights.

Best regards,

Christian

Former Member
0 Kudos

Hi Christian,

no, there doesn't seem to be a problem with the Services file: it's writeble, no access problems.

In the meantime we've been checking the filemon output again and we've noticed that there might be a problem with the SAPMSG.INI file instead of the Services file:

179 3:33:10 PM saplogon.exe:1184 OPEN C:\WINDOWS\SAPMSG.INI FILE NOT FOUND Options: Open Access: All

1180 3:33:10 PM saplogon.exe:1184 OPEN C:\WINDOWS\SAPMSG.INI FILE NOT FOUND Options: Open Access: All

1181 3:33:10 PM saplogon.exe:1184 OPEN D:\Documents and Settings\xxxxx\SapWorkDir\%systemRoot%\System32\drivers\etc\services PATH NOT FOUND Options: Open Access: All

We've now advised to check the SAPMSG.INI file, but as this is in the hands of Technical Field Services we have to wait for their input again. But we're still puzzled as to why a clean install of SAP is not fixing the problem.

Many thanks for your help.

Kind regards,

Candy

Christian_Cohrs
Advisor
Advisor
0 Kudos

Hi Candy,

I wonder why the SystemRoot environment variable was not expanded when accessing the services file. This should normally point to C:\Windows.

Could you check if this variable exists and has the correct value?

Best regards,

Christian

Former Member
0 Kudos

Almost looks like a Terminal Server installation with the D:\ drive and the redirect to the user profile instead of the system dir.