cancel
Showing results for 
Search instead for 
Did you mean: 

GRC AC10 While performing portal repository object sync (profiles, users and roles) nothing is found

miha_tesar
Explorer
0 Kudos
509

Dear experts,

I configured the connector for Access Request Provisioning for SAP Enterprise Portal system by following the steps provided in SAP Note 1607232 - GRC 10.0 Enterprise Portal Configuration. When I execute sync job Fetch IDM Schema no data is found. Also when I execute Repository Object Synch no portal user or roles are found.

 

Our GRC system is on SP08, portal is on NW 7.02 SPS11. Where should I look for an error?  I appreciate you help.

 

Best Regards,

Miha

Accepted Solutions (1)

Accepted Solutions (1)

neerajmanocha
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Miha,

There is one recent sap note released which is related to Portal. that is....1727530.

Could you please implement this. Hopefully this will resolve your portal data issue also.

Thanks & Regards

Neeraj

miha_tesar
Explorer
0 Kudos

Dear Neeraj,

 

I implemented note 1727530 and also note 1655074. Schema was imported successfully. Still no user or roles are found while performing Repository Object Sync. There is warning in SLG1 for
user sync saying "User Adapter is empty". 

 

This is the content of role sync log:

- Processing for connector EPD

- Get time stamp for full role sync

- Converting language for Web service new language: E

- Retrieving batch size

- Retrieving Role Range

- Role Range returned as empty for EPD connector, reason

- Starting role sync for connector EPD and language EN

- Executing role sync for the role master

- Calling get_role_list method

- Fetch criteria: sign = I option = CP low = * high =

- Date range from: 19.700.101.000.000 To: 20.120.607.115.231

- Create and modify roles

- Calling set_role method

- Executing role ORG Level data sync

- Executing role action sync for legacy system

- Executing role permission for legacy system

- Completed role synchronization for connector EPD and language EN

- Sync successful for connector EPD, language EN and total count : 0

- Updating excluded objects

- Updating last execution timestamp

- Sync completed for connector EPD

- Role sync successfully executed

    

This is the content of user sync log:

- Processing for connector EPD

- Retrieving batch size

- Retrieving User Range

- Starting user synchronization for connector EPD.

- Completing user sync

- Establishing user profile relation

- Establishing user-pdprofile relation

- Establishing user-role relation

- User Adapter is empty

- Updating excluded objects

- Updating last execution timestamp

- Sync successful for connector EPD and total count: 0

- Sync completed for connector EPD

- User sync successfully executed

Answers (1)

Answers (1)

miha_tesar
Explorer
0 Kudos

There was an error in Path Suffix in Logical Port configuration.

Best Regards,

Miha

neerajmanocha
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Miha,

So your issue resolved after making changes in Logical port configuration.

BTW.....

What was the Path Suffix earlier in logical port and what changes you made to fix this? This would be helpful for everyone, if you can share where exactly the changes required.

Thanks & Regards

Neeraj

Former Member
0 Kudos

Hi Miha

I have the same problem, could you explain me how you fix it? please.

Thank you.

Regards,

Leon

miha_tesar
Explorer
0 Kudos

Dear Leon,

Sorry for late reply.

There was a slash missing at the beginning of Path Suffix. I hope this helps you.

Best Regards,

Miha

Former Member
0 Kudos

Thank you!!

Regards!

Former Member
0 Kudos

Hi Miha,

I have the same issue.

Can u please tell me, where in SPRO have you edited the Path Suffix and what was the Path Suffix earlier in logical port and what changes you made to fix this?

Thank you in advance.

regards

Edgar

Former Member
0 Kudos

I could fix my issue by performing following steps:

1. SPRO > SAP Reference IMG > Governance, Risk and Compliance > Access Control > Maintain Data Sources Configuration

2. perform job GRAC_REPOSITORY_OBJECT_SYNC

also see thread https://scn.sap.com/thread/3351625

regards

Edgar

0 Kudos

Hello Edgar,

what type of Path Suffix do you have setted in SPRO? B012 or A002? Do you know the differences between them?

Kind regards,

Jakub