cancel
Showing results for 
Search instead for 
Did you mean: 

Error while displaying data using WebRFC

sivaganesh_krishnan
Contributor
0 Kudos

Hi Everyone,

I have created a webRFC , It displays personnel details by giving pernr number. I was able to get the output in the flavor , but in some case , its throwing error ,Suppose if the name is STEFAN PFÄNDILI,.  it contains a letters other than alphabets its thrwoing an error.

How to solve this issue.?

Thanks & Regards,

Sivaganesh

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

You say it is throwing an error. What error?

What happens if you run the function directly in SE37? Does it work or does it produce an error? What error?

What happens if you call the WebRFC URL directly in the browser, rather than via Personas? Does it work then, or does it produce an error? What error?

Do please try some of the obvious debugging steps before posting here. You'll get a solution more quickly that way. And if you've tried them already, say what happened so we have more information to help.

Steve.

sivaganesh_krishnan
Contributor
0 Kudos

Hi Steve,

Thanks for you response.

The WebRFC is working fine, i could see the data in the browser.

I have called the web RFC in the script and pasted the value with correct name.

But i am getting an error as below

I have tested the same for different scenario,  it works fine for normal text output but if the value contains any new symbols like the above one HAUPTSTRAßE , Its showing the same error as above.

Regards,

sivaganesh

Former Member
0 Kudos

Everything looks good to me, so I can only assume the Personas browser component is having difficulty parsing the non-ASCII text. Is your backend system a Unicode system?


I'd suggest opening an OSS message for this.


Steve.