cancel
Showing results for 
Search instead for 
Did you mean: 

BlackICE does not exist on 'localhost' host

Former Member
0 Kudos
52

Hello,

I am trying to install the SAP NW2004s SR3 Java Developer Version on my laptop.

But before the installation begins, i.e after I enter the parameters, I get the following error:

The subkey 'HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BlackICE' does not exist on the 'localhost' host.

Any idea how to resolve this?

Thanks and Regards,

Reena

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

Hello Reena,

do you have administrative user rights?

Here is a comment from the following blog --> [link|https://www.sdn.sap.com/irj/sdn/weblogs?blog=/pub/wlg/2086] [original link is broken] [original link is broken] [original link is broken];

Hi

Had a similar problem with NW2004s on my machine with the following error:

ERROR 2007-05-30 10:21:25

MOS-01185 The subkey 'HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesBlackICE' does not exist on the 'localhost' host.

The Solution was to delete and recreate the registry entry from another similarly configured machine. After more discussion among colleagues there may be another explanation in that the registry hive permissions did not allow sapinst to read the affected key and thus it returned an error.

Best Regards

Peta M Gergen

I have a WinXP SP2 machine here and don't have this registry key either.

So which operating system do you use?

Regards,

Norman Schru00F6der

Former Member
0 Kudos

Hi Norman,

Thanks a lot for you reply.

Actually, I was able to figure out that this had something to with "Proventia Desktop Protection" application that was running on my computer. I disabled this application and then tried. It worked after that

Anyway... mine is a WinXP(dont know the SP level though). So probably I wouldn't have been able to alter the registry entry either, although I have admin rights.

Thanks once again.

Regards,

Reena