cancel
Showing results for 
Search instead for 
Did you mean: 

Work center missing in Work Manager

0 Kudos
219

Hi guru's,

I have some trouble with SAP Work Manager 6.3. I've setup a local server with SMP 3.0.10.0, deployed the standard WM 6.30 app and connect to our ECC system through the WPF or ATE client.

Lots of data comes in, until the point where it says:

Checking Get WorkOrders...

GetWorkOrdersSteplet - <value missing for PROBLEM_BAPI_CREATE>

Checking the SMP server log, this relates to:

2016 01 20 15:18:14#+0100#INFO#System.out###Agentry SAPWM Worker Thread#########User::getString::Property: fetch.WorkCenter =  |

-> value for Work center is empty

Resulting in:

2016 01 20 15:18:20#+0100#INFO#System.out###Agentry SAPWM Worker Thread#########setImportParameters::COM.SYCLO.AGENTRY.BUSINESSLOGICEXCEPTION: <VALUE MISSING FOR WORK_CENTER_NOTFOUND_FETCH> |

And eventually:

2016 01 20 15:18:20#+0100#INFO#System.out###Agentry SAPWM Worker Thread#########throwExceptionToClient::com.syclo.sap.component.workorder.steplet.GetWorkOrdersSteplet::throwExceptionToClient::27106::GetWorkOrdersSteplet - <value missing for PROBLEM_BAPI_CREATE> |

Backend configuration seems to be okay: user is assigned to work center BSV-OHD, work orders for that work center are released.

Other configuration done is setting Assignment type to 8 (both in global client as well as workorder_generic screens), user parameter VAP has been maintained to BSV-OHD for our test user.

When using ATE we see the work center value in table ctUser for VAP parameter: BSV-OHD. Somehow this value is lost in the process, resulting in the error during transmit so no work orders are sent to the client.

Please help.

Kind regards,

Hilco

Accepted Solutions (1)

Accepted Solutions (1)

stephen_kringas
Active Participant
0 Kudos

Hi Hilco,

Please check the SAP Note -

2269351 - GetWorkOrdersSteplet - Problem in BAPI Create (/SMERP/PM_DOWORKORDER_GET):Work center not ...

It describes your issue and the solution.

Cheers,

Stephen

mark_pe
Active Contributor
0 Kudos

Stephen Kringas,

Thanks for the assist by providing our newly release SAP Support KBA article (it just got released like ~ 2 days ago).

@Hilco - We in the SAP Mobile support team agrees to Stephen's recommendation as we just got this fixed this last few days.  We have additional fix coming in the pipe-line for additional issues.

Best Regards,

SAP Mobile Support Team

0 Kudos

Hi Stephen,

Thank you very much, that fix solved our issue indeed!

Cheers, Hilco

0 Kudos

Hi Mark,

Thank you for the additonial information.

Kind regards,

Hilco

Answers (0)