cancel
Showing results for 
Search instead for 
Did you mean: 

WEBide : Fiori extension project deployment

laurent_touillaud
Contributor
0 Kudos
1,163

Hello,

I have created extension project extending a standard Fiori application (service MM_PO_APV) successfully on WEBide.

Testing on Webide is ok.

Now when i deploy to ABAP the bsp is created but testing service file "index.html" results to error :

404

File sap/zmm_po_apv/test-resources/sap/ushell/bootstrap/sandbox.js NOT found!


What is wrong?


Best regards,

Laurent.

0 Kudos

Team,

I am facing the same issue. Could you please share the resolution to the above ?

Regards,

Priya

Accepted Solutions (0)

Answers (3)

Answers (3)

0 Kudos

Issue resolved. Its the way we configure the tile (target mapping) in our Fiori Launchpad designer.

Configure it as "SAPUI5 Fiori App" under application type.

Mention the URL(mention the extended BSP app name) and ID(from your component) and thats it.

It will work like a charm.

Regards,

Priya

kulkasoh
Explorer
0 Kudos

Hi,

I was curious if you had to create a new tile for the Extension project application or we change the target mappings for standard application tile, so that we don't create a new tile?

Thank You.

jamie_cawley
Advisor
Advisor
0 Kudos

The sandbox.js does not exist on an abap system, it's part of web ide for testing.  Fiori type apps should be configured in the launchpad.

Regards,

Jamie

SAP - Technology RIG

laurent_touillaud
Contributor
0 Kudos

Hello,

I configured the app in the launchpad as mentionned in previous post but each time we start thee launchpad there are errors in the gateway system :

"No customer found"

"No Service found for namespace"

"gbapp_prapproval" and "sra001_pcapproval"

/IWFND/ERROR_LOG :

And the tile of extended app in FLP is not showing up whereas tile of standard app is showing and working.

Do you know if these errors are the source of the problem?

BR,

Laurent.

jamie_cawley
Advisor
Advisor
0 Kudos

For the tile not showing up, you may be missing a step or two in the config, tile catalog and roles. Check the section "Adding Custom Apps to Fiori launchpad" at

  

For the gateway errors I would suggest posting a new thread in the fiori space

Regards,

Jamie

SAP - Technology RIG

michal_keidar
Active Contributor
0 Kudos

Hi,

Are you launching it from SE80 directly or via FLP? You should launch it via FLP.

Regards,
Michal.

laurent_touillaud
Contributor
0 Kudos

Hi Michal,

Thanks for your answer.

I tested it with both methods with same result but for FLP i can only use direct URL target configuration in tile.

If i configure the semantic object configuration the tile disappears from the FLP.

LPD_CUST conf :

UI2/SEMOBJ

FLP conf :

Any idea?

Bes/+t 3rega3rds,

Laurent/+

michal_keidar
Active Contributor
0 Kudos

I'm not sure how it should be configured but I think it's a problem of the LPD_CUST configuration. See this thread for example:

Regards,
Michal.