cancel
Showing results for 
Search instead for 
Did you mean: 

Webi schedule failure

Former Member
0 Kudos
94

I have a webi report against BW data using BICS connection which is scheduled to run every week. The schedule fails with the error" while trying to invoke the method com.sap.ip.bi.bics.dataaccess.provider.selector.IProviderInfoObject.getName() of an object loaded from field com.sap.ip.bi.bics.dataaccess.consumer.impl.selector.InfoObject.providerInfoObject of an object loaded from local variable 'this' " but completes successfully when scheduled with "run now" option.

The report itself takes 15-20 min to run.

I have tried changing the timeout parameters.

Has anyone else faced similar issue??

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

What Authentication mode are you using in your BICS connection? We've found that if you use "Single Sign On", scheduled reports often fail if the owner isn't logged on at the time the report is run. It seems the Job Server sometimes (not always) fails to create a proper session for the BICS query. The error we get is "Cannot connect to the olap source nnnnnnnnnnnnn.Olap Exception: [Internal] SSO token or User password is empty." We are on BI 4.0 SP5.

Former Member
0 Kudos


Sorry for the late reply.

We found a solution to this issue.We had the -request timeout parameter set in the APS. It looks like there is some case sensitivity on the parameter. We had to modify it to "RequestTimeout". The reports now seem to work fine.

Former Member
0 Kudos

Hi Shaheen,

We are facing similar issue.

Can you please clarify few things, so that I can try implementing this my environment.

1) The "RequestTimeout" parameter was set on which APS? I am assuming you have split your APS as recommended. Was it for APS for DSL Bridge?

2) What is the value of timeout you set? What is the recommended value?

3) Is there any particular SAP Note you found in this respect.

Waiting for your response.

Thanks,

Sameer

Former Member
0 Kudos


Hi Sameer,

Yes, we have split our APS. The request time out paremeter is set on the DSL BRIDGE APS which has the following services

DSL Bridge Service

Security Token Service

TraceLog Service

WebIntelligence Monitoring Service

and also on the web Intelligence Processing server which has these services

Information Engine Service

Single Sign-On Service

TraceLOg Service

Web Intelligence Common Service

Web Intelligence Core Service

Web Intelligence Processing Service

The value is set to 7200000. Let me know if this helps.

Regards,

Shaheen

Former Member
0 Kudos

Hi Shaheen,

Thanks for your response.

We have this request timeout parameter set to 7200000 in WebI processing server but not in aps(dsl).

Were you able to find the exact cause of this issue? Also is requesttimeout property and enginecleanup time property for APS (dsl) same?

Thanks,

Sameer

Former Member
0 Kudos

Iam not sure if it is the root cause, but we did find that the queries were pulling a lot of unwanted variables which was taking a long time to even get completed in the BEx query itself.

As far as your next question. These are two different settings. The requesttime out property is set at the command line of the APS and the engine cleanup time property is set at the properties of the APS.

Former Member
0 Kudos

Hi, we had similiar issues with our BI 4.1 SP3 Patch 1. After installing Patch 3 the problem is solved. I think you should install the newest patch for your 4.0 SP6.

Best regards,

Benni

Former Member
0 Kudos

what support pack are you on?

-Nikhil Nair

Former Member
0 Kudos


We are currently on BI 4.0 sp6