cancel
Showing results for 
Search instead for 
Did you mean: 

WebDynpro Portal Eventing

Former Member
0 Kudos
62

Hi I tried to communicate with 2 iViews thro portal eventing.

a) in my iView1 I have a action.

on click of button I am calling this action..

public void onActionShow(com.sap.tc.webdynpro.progmodel.api.IWDCustomEvent wdEvent )

{

//@@begin onActionShow(ServerEvent)

String name = wdContext.currentContextElement.getName();

WDPortalEventing.fire("urn:com.sap.tc.webdynpro.example.portaleventing","Show",name);

//@@end

}

b) In my iView2 I have a code in my view wdDoInit method

WDPortalEventing.subscribe("urn:com.sap.tc.webdynpro.example.portaleventing","Show",wdThis.wdGetReactPortalEventingAction());

And my action is

public void onActionReactPortalEventing(com.sap.tc.webdynpro.progmodel.api.IWDCustomEvent wdEvent, java.lang.String dataObject )

{

//@@begin onActionReactPortalEventing(ServerEvent)

wdContext.currentContextElement().setName(dataObject);

//@@end

}

I have created a page in portal and I put these 2 iViews in that page.

If i try to run this application thro portal,its running and showing 2 iViews.but on click of the button the event is not calling the second iView.

Can anyone help me in this..

I followed everything specified in HowToProgramPortalEventing.pdf.

Can anyone tell me what mistake I've done..

Is that the path correct?

Thankx in advance

Regards,Swapna

Accepted Solutions (0)

Answers (4)

Answers (4)

Former Member
0 Kudos

Hello,

Did you look at this note 1112733?

Former Member
0 Kudos

Swapna,

Can you send me the link to the HowToProgramPortalEventing.pdf doc?

Regards,

James

Former Member
Former Member
0 Kudos

In the document "How to Use Portal Eventing for Web Dynpro iViews" it is stated that portal server and WebDynpro J2EE server must have the same domain.

E.G.:

http://XXXX.a.b.com and

http://YYYY.a.b.com

In my tests portal eventing does not work if I connect to the portal server with https while the WebDynpro runs on http. Is that also part of the domain? Can I solve the problem by starting the WebDynpro via https?

I'd be thankful for a short reply...

Matthias

MarcoErtel
Advisor
Advisor
0 Kudos

Hi Swapna,

how have you opened the portal in your browser? Have you used the full qualified hostname? This is needed, depending to the domain name relaxation setting.

Kind Regards

Marco