cancel
Showing results for 
Search instead for 
Did you mean: 

WAS Installation for XI

Former Member
0 Kudos
65

Hi all,

We want to install XI.

In order to do so, I understood we should install ABAP+Java WAS (Add-ins).

In Sap Service Marketplace, I found only installation guides for XI and Java WAS.

Where can I find an installation guide for ABAP+Java WAS (Add-ins)?

I have Netweaver kernel unicode, and I tried to install it intuitively.

I first installed ABAP WAS, and the installation finished successfully.

I then tried to install java add-ins, and got an error message saying it couldn’t connect to the ABAP System and that I should check that it’s started.

In MMC process list I saw:

msg_server – running.

disp+work.exe – stopped.

igswd – running.

When I tried to start disp+work.exe, it started and immediately stopped again.

Any help will be appreciated.

Thanks ahead,

Yoav.

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Yoav,

Please check the log files

from ..\usr\sap\<sid>\dve..\work folder. dev_disp etc

might give a clear idea of the problem.

Regards

Srikishan

Former Member
0 Kudos

<b>The dev_disp log content is :</b>

-


trc file: "dev_disp", trc level: 1, release: "640"

-


Thu Feb 02 19:20:20 2006

kernel runs with dp version 128000(ext=102000) (@(#) DPLIB-INT-VERSION-128000-UC)

length of sys_adm_ext is 524 bytes

systemid 560 (PC with Windows NT)

relno 6400

patchlevel 0

patchno 43

intno 20020600

make: multithreaded, Unicode

pid 2280

***LOG Q00=> DpSapEnvInit, DPStart (00 2280) [dpxxdisp.c 1100]

shared lib "dw_xml.dll" version 43 successfully loaded

shared lib "dw_xtc.dll" version 43 successfully loaded

shared lib "dw_stl.dll" version 43 successfully loaded

shared lib "dw_gui.dll" version 43 successfully loaded

Thu Feb 02 19:20:25 2006

      • WARNING => DpNetCheck: NiAddrToHost(1.0.0.0) took 5 seconds

***LOG GZZ=> 1 possible network problems detected - check tracefile and adjust the DNS settings [dpxxtool2.c 3886]

MtxInit: -2 0 0

DpSysAdmExtInit: ABAP is active

DpSysAdmExtInit: JAVA is not active

DpShMCreate: sizeof(wp_adm) 10528 (1316)

DpShMCreate: sizeof(tm_adm) 2780232 (13832)

DpShMCreate: sizeof(wp_ca_adm) 24000 (80)

DpShMCreate: sizeof(appc_ca_adm) 8000 (80)

DpShMCreate: sizeof(comm_adm) 290000 (580)

DpShMCreate: sizeof(vmc_adm) 0 (372)

DpShMCreate: sizeof(wall_adm) (38456/34360/64/184)

DpShMCreate: SHM_DP_ADM_KEY (addr: 061F0040, size: 3192688)

DpShMCreate: allocated sys_adm at 061F0040

DpShMCreate: allocated wp_adm at 061F1B58

DpShMCreate: allocated tm_adm_list at 061F4478

DpShMCreate: allocated tm_adm at 061F44A0

DpShMCreate: allocated wp_ca_adm at 0649B0E8

DpShMCreate: allocated appc_ca_adm at 064A0EA8

DpShMCreate: allocated comm_adm_list at 064A2DE8

DpShMCreate: allocated comm_adm at 064A2E00

DpShMCreate: allocated vmc_adm_list at 064E9AD0

DpShMCreate: system runs without vmc_adm

DpShMCreate: allocated ca_info at 064E9AF8

DpShMCreate: allocated wall_adm at 064E9B00

MBUF state OFF

EmInit: MmSetImplementation( 2 ).

<ES> client 0 initializing ....

<ES> InitFreeList

<ES> block size is 1024 kByte.

Using implementation flat

<EsNT> Memory Reset disabled as NT default

<ES> 1909 blocks reserved for free list.

ES initialized.

rdisp/http_min_wait_dia_wp : 1 -> 1

***LOG CPS=> DpLoopInit, ICU ( 2.6.1 2.6 4.0) [dpxxdisp.c 1462]

***LOG Q0K=> DpMsAttach, mscon ( sapxi) [dpxxdisp.c 9736]

CCMS: Initalizing shared memory of size 60000000 for monitoring segment.

CCMS: start to initalize 3.X shared alert area (first segment).

DpMsgAdmin: Set release to 6400, patchlevel 0

MBUF state PREPARED

MBUF component UP

DpMBufHwIdSet: set Hardware-ID

***LOG Q1C=> DpMBufHwIdSet [dpxxmbuf.c 1025]

DpMsgAdmin: Set patchno for this platform to 43

Release check o.K.

Thu Feb 02 19:21:05 2006

      • ERROR => W0 (pid 2496) died [dpxxdisp.c 12187]

      • ERROR => W1 (pid 3592) died [dpxxdisp.c 12187]

my types changed after wp death/restart 0xbf --> 0xbe

      • ERROR => W2 (pid 280) died [dpxxdisp.c 12187]

my types changed after wp death/restart 0xbe --> 0xbc

      • ERROR => W3 (pid 524) died [dpxxdisp.c 12187]

my types changed after wp death/restart 0xbc --> 0xb8

      • ERROR => W4 (pid 1924) died [dpxxdisp.c 12187]

      • ERROR => W5 (pid 3360) died [dpxxdisp.c 12187]

my types changed after wp death/restart 0xb8 --> 0xb0

      • ERROR => W6 (pid 3316) died [dpxxdisp.c 12187]

my types changed after wp death/restart 0xb0 --> 0xa0

      • ERROR => W7 (pid 2984) died [dpxxdisp.c 12187]

my types changed after wp death/restart 0xa0 --> 0x80

      • DP_FATAL_ERROR => DpWPCheck: no more work processes

      • DISPATCHER EMERGENCY SHUTDOWN ***

increase tracelevel of WPs

killing W0-2496 (SIGUSR2)

      • ERROR => DpWpKill(2496, SIGUSR2) failed [dpxxtool.c 2468]

killing W1-3592 (SIGUSR2)

      • ERROR => DpWpKill(3592, SIGUSR2) failed [dpxxtool.c 2468]

killing W2-280 (SIGUSR2)

      • ERROR => DpWpKill(280, SIGUSR2) failed [dpxxtool.c 2468]

killing W3-524 (SIGUSR2)

      • ERROR => DpWpKill(524, SIGUSR2) failed [dpxxtool.c 2468]

killing W4-1924 (SIGUSR2)

      • ERROR => DpWpKill(1924, SIGUSR2) failed [dpxxtool.c 2468]

killing W5-3360 (SIGUSR2)

      • ERROR => DpWpKill(3360, SIGUSR2) failed [dpxxtool.c 2468]

killing W6-3316 (SIGUSR2)

      • ERROR => DpWpKill(3316, SIGUSR2) failed [dpxxtool.c 2468]

killing W7-2984 (SIGUSR2)

      • ERROR => DpWpKill(2984, SIGUSR2) failed [dpxxtool.c 2468]

NiWait: sleep (10000 msecs) ...

NiISelect: timeout 10000 ms

NiISelect: maximum fd=1597

NiISelect: read-mask is NULL

NiISelect: write-mask is NULL

Thu Feb 02 19:21:15 2006

NiISelect: TIMEOUT occured (10000 ms)

dump system status

Workprocess Table (long) Thu Feb 02 17:21:15 2006

========================

No Ty. Pid Status Cause Start Err Sem CPU Time Program Cl User Action Table

-


0 DIA 2496 Ended no 1 0 0

1 DIA 3592 Ended no 1 0 0

2 UPD 280 Ended no 1 0 0

3 ENQ 524 Ended no 1 0 0

4 BTC 1924 Ended no 1 0 0

5 BTC 3360 Ended no 1 0 0

6 SPO 3316 Ended no 1 0 0

7 UP2 2984 Ended no 1 0 0

Dispatcher Queue Statistics Thu Feb 02 17:21:15 2006

===========================

--------


+
+

+

+
--


+

Typ

now

high

max

writes

reads

--------


+
+

+

+
--


+

NOWP

0

3

2000

10

10

--------


+
+

+

+
--


+

DIA

5

5

2000

5

0

--------


+
+

+

+
--


+

UPD

0

0

2000

0

0

--------


+
+

+

+
--


+

ENQ

0

0

2000

0

0

--------


+
+

+

+
--


+

BTC

0

0

2000

0

0

--------


+
+

+

+
--


+

SPO

0

0

2000

0

0

--------


+
+

+

+
--


+

UP2

0

0

2000

0

0

--------


+
+

+

+
--


+

max_rq_id 13

wake_evt_udp_now 0

wake events total 9, udp 8 ( 88%), shm 1 ( 11%)

since last update total 9, udp 8 ( 88%), shm 1 ( 11%)

Dump of tm_adm structure: Thu Feb 02 17:21:15 2006

=========================

Term uid man user term lastop mod wp ta a/i (modes)

Workprocess Comm. Area Blocks Thu Feb 02 17:21:15 2006

=============================

Slots: 300, Used: 1, Max: 0

--------


+
+
--


+

id

owner

pid

eyecatcher

--------


+
+
--


+

0

DISPATCHER

-1

WPCAAD000

NiWait: sleep (5000 msecs) ...

NiISelect: timeout 5000 ms

NiISelect: maximum fd=1597

NiISelect: read-mask is NULL

NiISelect: write-mask is NULL

Thu Feb 02 19:21:20 2006

NiISelect: TIMEOUT occured (5000 ms)

Shutdown server ...

DpJ2eeDisableRestart

DpModState: buffer in state MBUF_PREPARED

NiBufSend starting

NiIWrite: write 110, 1 packs, MESG_IO, hdl 3, data complete

MsINiWrite: sent 110 bytes

MsIModState: change state to SHUTDOWN

DpModState: change server state from STARTING to SHUTDOWN

Switch off Shared memory profiling

ShmProtect( 57, 3 )

ShmProtect(SHM_PROFILE, SHM_PROT_RW

ShmProtect( 57, 1 )

ShmProtect(SHM_PROFILE, SHM_PROT_RD

DpWakeUpWps: wake up all wp's

Stop work processes...

Stop gateway

killing process (3972) (SOFT_KILL)

Stop icman

killing process (3328) (SOFT_KILL)

Terminate gui connections

[DpProcDied] Process lives (PID:3972 HANDLE:1576)

waiting for termination of gateway

NiWait: sleep (1000 msecs) ...

NiISelect: timeout 1000 ms

NiISelect: maximum fd=1597

NiISelect: read-mask is NULL

NiISelect: write-mask is NULL

Thu Feb 02 19:21:21 2006

NiISelect: TIMEOUT occured (1000 ms)

[DpProcDied] Process died (PID:3972 HANDLE:1576)

[DpProcDied] Process died (PID:3328 HANDLE:1568)

DpHalt: cancel all lcom connections

MPI CancelAll 2 -> 0

MPI DeleteAll 2 -> 0

NiIMyHostName: hostname = 'sapxi'

AdGetSelfIdentRecord: > <

AdCvtRecToExt: opcode 60 (AD_SELFIDENT), ser 0, ex 0, errno 0

AdCvtRecToExt: opcode 4 (AD_STARTSTOP), ser 0, ex 0, errno 0

DpConvertRequest: net size = 163 bytes

NiBufSend starting

NiIWrite: write 562, 1 packs, MESG_IO, hdl 3, data complete

MsINiWrite: sent 562 bytes

send msg (len 110+452) to name -, type 4, key -

detach from message server

***LOG Q0M=> DpMsDetach, ms_detach () [dpxxdisp.c 9962]

NiBufSend starting

NiIWrite: write 110, 1 packs, MESG_IO, hdl 3, data complete

MsINiWrite: sent 110 bytes

MsIDetach: send logout to msg_server

MsIDetach: call exit function

DpMsShutdownHook called

NiSelClear: removed hdl 3 from selectset

MBUF state OFF

AdGetSelfIdentRecord: > <

AdCvtRecToExt: opcode 60 (AD_SELFIDENT), ser 0, ex 0, errno 0

AdCvtRecToExt: opcode 40 (AD_MSBUF), ser 0, ex 0, errno 0

AdCvtRecToExt: opcode 40 (AD_MSBUF), ser 0, ex 0, errno 0

blks_in_queue/wp_ca_blk_no/wp_max_no = 1/300/8

LOCK WP ca_blk 1

make DISP owner of wp_ca_blk 1

DpRqPutIntoQueue: put request into queue (reqtype 1, prio LOW, rq_id 19)

MBUF component DOWN

NiBufClose: clear extensions for hdl 3

NiBufSetStat: bufstat of hdl 3 changed from OK to OFF

NiICloseHandle: shutdown and close hdl 3 / socket 1580

MsIDetach: detach MS-system

EsCleanup ....

***LOG Q05=> DpHalt, DPStop ( 2280) [dpxxdisp.c 8495]

Good Bye .....

I appreciate if anyone guide me how to solve the problem and where can I find the installation guide for WAS add-ins (java_abap)

Thanks

Yoel +Yoav

Former Member
0 Kudos

Hi,

Please check the memory, it might be a problem. I'm trying

to find the cause as to why all the work processes are

dying.

Also the Installation guide is available at the following

link https://websmp103.sap-ag.de/instguidesNW04 -->

Release 04 --> Installation --> SAP WEB AS ---> SAP Web

AS 6.40 and Related Documentation -> SAP Web AS Java.

Regards

Srikishan

Former Member
0 Kudos

hi Yoel

> *** DP_FATAL_ERROR => DpWPCheck: no more work

> processes

> *** DISPATCHER EMERGENCY SHUTDOWN ***

Incorrect requests are rejected by the dispatcher, and the instance is no longer terminated.

In addition to this, the patch level specified in the Note prevents an emergency shutdown from being executed because of a queue overflow.

Refer note <b>916050 & 501902</b>.

Regards

Arun

Former Member
0 Kudos

hey,

did your problem get solved? if so, post the solution too

Regards

Arun.

Former Member
0 Kudos

No solution yet.

Hopefully we will get back to work on it sometime next week.

I'll update the thread then.

Yoav.

Former Member
0 Kudos

Hi all,

The dev_w0 contains:

np:(local) connection used on SAPXI

C Failed to initialize provider SQLNCLI. See note #734034 for more information.

C Using provider SQLOLEDB instead.

C OpenOledbConnection: Failed to set MARS property.

C ExecuteAndFlush return code: 0x80004005 Stmt: [use SXI ]

C ExecuteAndFlush: line 5731. hr: 0x80004005 Could not locate entry in sysdatabases for database 'SXI'. No entry found with that name. Make sure that the name is entered correctly.

C sloledb.cpp [ExecuteAndFlush,line 5731]: Error/Message: (err 911, sev 0), Could not locate entry in sysdatabases for database 'SXI'. No entry found with that name. Make sure that the name is entered correctly.

C Procname: [ExecuteAndFlush - no proc]

C OpenOledbConnection : Failed to switch to specified database SXI

Which indicates there is a problem connecting to database SXI.

Is it possible that although we got a message saying the install was successfull, the DB wasn't created properly?

Strange enough, when I open SQL Enterprise Manager, I don't see a DB named SXI under local.

Any clues?

Thanks ahead,

Yoav.

Former Member
0 Kudos

hi Yoav,

> C Failed to initialize provider SQLNCLI. See note

> #734034 for more information.

Did u check that particular note? in case you had not, here it is.

<i>Symptom

The following warning message appears in developer trace files:

C Failed to initialize provider SQLNCLI. See note #734034 for more information.

C Using provider SQLOLEDB instead.

Please NOTE: This is a warning message only. It is meant to remind users to apply the SQL 2005 client libraries whenever they become available. These client libraries are referred to as SNAC and the OLEDB provider is named SQLNCLI. The SQL 2005 is now officially available at this time (Jan. 2006).

For SQL 2000 users:

It is recommended that you use the new provider even though the system runs perfectly fine with the older SQLOLEDB provider.

For SQL 2005 users:

SAP enforces the use of SNAC/SQLNCLI for any connections to SQL 2005. This means that R/3 will not run on an application server without the use of SNAC. In this case the message in the developer trace file looks like this:

C You must use SNAC to access SQL 9.0 or later. See note #734034

Reason and Prerequisites

A new Native SQL Oledb provider is available in SQL 2005. SAP recommends the use of this new provider for all SAP versions 6.10 and later. Also SAP recommends to use the new provider as a client even for SQL 2000 Servers.

Solution

Install the sql native provider on the application server(s) where these messages appear.

Use either the SQL 2005 installation CD or the website:

http://www.microsoft.com/downloads/

To install the SQLNCLI provider software.

To install from the SNAC client only (without any other tools), you

can run <CD_DRIVE>:\Setup\sqlncli.msi</i>

from this i guess something is wrong with your version of SQL. Probably the latest would help you out!

Regards

Arun

Former Member
0 Kudos

Hi,

I checked the Note, and it wasn't relevant.

However, It appears that the problem was with the installation.

A new installation solved the problem.

Thanks for all who helped.

Yoav.

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi

Yoav,

i need the label.asc file for unicode abap+java

its asking for kernel path of label.asc...but i could find the file in my dvd's...

if u send me the rquired file ill be more appreciated..

thanks,

eswar

Former Member
0 Kudos

Hi

51030771

I hope it solve the problem. If not please let me know.

Yoel Malekan

Former Member
0 Kudos

Hi Yoel,

i am stuck with xi installtion.can u please help me for the unicode kernel path of label.asc file,i couldnt

find that file in my CD's.i was strucked for 2months regarding this problem.

i am vry helpful if u slove my problem

thanks

eswar

Former Member
0 Kudos

Hi Eswar

For installing java add-ins and XI you should do the following :

1- Data Base Installation.

2- ABAP Unicode – Central

3- ABAP Unicode – Database Instance

4- Java Add-In for ABAP

5- Exchange Infrastructure

After that please perform the post installation task and install license for java and ABAB stuck.

BTW - instead the specific path for label.asc you can inter the path of the required disk.

Good Luck

Yoel

Former Member
0 Kudos

Hi Yaov,

Please paste the trace dev_w0.

regards

Anand.M

Former Member
0 Kudos

hi Yoav,

> I then tried to install java add-ins, and got an

> error message saying it couldn’t connect to the ABAP

> System and that I should check that it’s started.

THis could be because of many reasons.

Some of them are

  • Java Heap size - should be less than 1/4 of your System RAM.

  • Your INSTALLATION PARAMETERS which you gave during the abap central-db instance. and your Java Addin should be pointing to this instance.

> In MMC process list I saw:

> msg_server – running.

> disp+work.exe – stopped.

> igswd – running.

> When I tried to start disp+work.exe, it started and

> immediately stopped again.

Can you please give more details from the LOG?

Regards

arun