cancel
Showing results for 
Search instead for 
Did you mean: 

WAD BI 7 and Navigation pane

former_member206720
Participant
0 Kudos
69

Team:

I took a copy of the 0analysis_pattern WAD. I have two issues, as follows:

1. I would like to set the tray to u201Conu201D. This will help us getting the output of 16 columns of the original report on the monitor and of course to hide the navigation pane. I set the box u201Cwith trayu201D but the caption is not display in the output report.

2. Using the same, WAD, I inserted a container to host a couple of tabs. Sadly, the WAD does not display the two tabs. On the other hand, when I produce my own WAD from scratch, the report produces the two tabs I set previously. If I continue using this WAD the SAP toolbar showing the following pushbuttons new analysis, open, save as, information, etc disappear. This toolbar is a must to have. I copied from the original WAD but the toolbar is not displayed in the output.

I have read the help.sap.com over the years so that I fully aware of what is contained there.

Any idea is welcome

RAP

Accepted Solutions (1)

Accepted Solutions (1)

former_member595061
Contributor
0 Kudos

Hi,

1. Try to set the tray for the FILTER_GROUP_AREA in the copied version of 0ANALYSIS_PATTERN.

2. a) For the tab item: Where did you insert the tab item in the template?

b) If you want the buttons to be displayed in your template, you can just copy the definitions of the following button groups: BUTTON_OPEN_SAVE and BUTTON_TOOLBAR_2.

Best regards,

Janine

former_member206720
Participant
0 Kudos

Janine:

Thank you for your reply. Tray issue is gone. The tab case is the one now pesting me.

I placed the tabstrip_container_item_1 inside container layour content, just below and outside the chart icon. The tastrip_container_item_1 has to containers, as follows:

Container 1:

  • Nav pane 1

  • Query 1

Container 2:

  • Nav pane 2

  • Query 2

The output display is the query set for the original query embedded in the default table. That is to say, the template is ignoring my tabs. I placed the tabs outside the content area and the tabs were display. If I use my own WAD I will loose the SAP toolbar and my case this is needed. IN relation to the buttons they are not needed. My customers want to see the tabs + SAP toolbar on top.

Is there information explanining how 0ANALYSIS_PATTERN works? Any idea is welcome.

Regards

RAP

former_member595061
Contributor
0 Kudos

Hi RAP,

I just tested this:

+) add the tabstripitem with the container items underneath the chart item into the container_layout_content

+) validate the template on the server by pressing the button or simply switching between the XHTML and Layout Tab once to let the container item know that new items have been added

+) Now go to the properties of the container_layout_content. Click on the button next to 'row'. Add a new row for your tabstrip item and choose the tabstrip item as subordinate item.

+) save and execute

Best regards,

Janine

former_member206720
Participant
0 Kudos

Janine:

I figured it out yesterday. You are certainly spot on.

I read your answers to other topics, which they were very accurate. Please keep up the good work.

Regards

RAP

former_member206720
Participant
0 Kudos

Janine:

Well done.

Answers (1)

Answers (1)

former_member206720
Participant
0 Kudos

I do not know how to award points.