cancel
Showing results for 
Search instead for 
Did you mean: 

Update Statistics from brtools is failing

Former Member
0 Kudos
729

Guys,

Problem is related with Updating the Statistics using brtools. I am trying to execute the update statistics using brtools and it is giving me below error.

BR0801I BRCONNECT 6.40 (50)

BR0805I Start of BRCONNECT processing: cedkvgsc.sta 2010-06-11 15.33.34

BR0484I BRCONNECT log file: /oracle/QA1/sapcheck/cedkvgsc.sta

BR0280I BRCONNECT time stamp: 2010-06-11 15.33.35

BR0301E SQL error -1017 at location db_connect-2

ORA-01017: invalid username/password; logon denied

BR0310E Connect to database instance QA1 failed

BR0280I BRCONNECT time stamp: 2010-06-11 15.33.35

BR0301E SQL error -1017 at location db_connect-2

ORA-01017: invalid username/password; logon denied

BR0310E Connect to database instance QA1 failed

BR0806I End of BRCONNECT processing: cedkvgsc.sta 2010-06-11 15.33.35

BR0280I BRCONNECT time stamp: 2010-06-11 15.33.35

BR0804I BRCONNECT terminated with errors

However, from brtools I can perform the other tasks like Table Reorganization or checking the status of tablespaces. It was working earlier. Permissions for br* file are same as on other systems where it is working. I have check the db ids and none of them are locked or password expired. You can refer below.

SQL> select username, account_status from dba_users;

USERNAME ACCOUNT_STATUS

-


-


SAPPRD OPEN

OPS$QA1ADM OPEN

SAPQA1 OPEN

SAPR3 OPEN

SHAFIQ OPEN

PARMAR OPEN

TSHISHIR OPEN

AMBRISH OPEN

KAUSTAV OPEN

DBSNMP EXPIRED & LOCKED

OUTLN EXPIRED & LOCKED

USERNAME ACCOUNT_STATUS

-


-


MAHESH OPEN

SJETTU OPEN

VISHALK OPEN

PERFSTAT OPEN

BVIJAY OPEN

SYS OPEN

SYSTEM OPEN

18 rows selected.

Note - I am using ora id only and if i execute it from SAP level it works fine. I have tried all type of permissions for brconnect file.

What could be the problem?

Thanks and Regards,

Kedar Malekar

Edited by: Kedar Malekar on Jun 11, 2010 12:43 PM

Accepted Solutions (1)

Accepted Solutions (1)

former_member227283
Active Contributor
0 Kudos

Hi,

Login to Sqlplus with sysdba and the run the following command and let us know the output.

connect /@QA1

Thanks

Anil

Former Member
0 Kudos

Thanks a lot Anil for all your efforts in helping me to solve this issue. You deserve 100 out 10... rather than 10 out of 10.

Best Regards,

Kedar

Answers (2)

Answers (2)

Former Member
0 Kudos

Well sometimes ... this weird and just try to re-create your OPS$user... follow the given commands !

sqlplus /nolog

SQL> connect / as sysdba

SQL> create user ops$ora<sid> identified externally temporary tablespace psaptemp;

SQL> grant connect, sapdba to ops$ora<sid>;

And after this try to use BRTOOLS/DB13.. I hope it will solve your issue !

Former Member
0 Kudos

Hi,

Try executing brtools with <SIDADM> login. If that does not work refer the Note 400241 - Problems with ops$ or sapr3 connect to Oracle.

Regards,

Sharath