Showing results for 
Search instead for 
Did you mean: 

Unable to connect to SAP using 64bit dlls, whereas it works with 32bit C#

0 Kudos

Hi Team,

I facing a issue when using the 64bit versions of icudt50.dll, icuin50.dll, icuuc50.dll in my code.
This fails with the error pop-up message as, "above dlls path needs to be added to PATH variable". I have added them, but still it fails. I have added them as part of project reference as well.

Whereas, the 32bit of these dlls are working fine.

Here is a screenshot for the same

if we echo PATH, we can see that these dlls are added there

I tried to restart, add path again and again, deleted these dlls and added them one more time but still getting the same error.

Can anyone help me out here?

Product and Topic Expert
Product and Topic Expert

Could you please provide more details? What exactly are you doing? NCo does not need the ICU libraries, hence it must be some different scenario/setup.

Best regards,

0 Kudos

Hi markus.tolksdorf

I'm using the package to connect to SAP.
With 32 bit dlls, this is working as per expectations, I'm able to connect to SAP and Remote FM but with 64bit dlls it is giving the above mentioned error even when PATH is set.

I started with SapNCo but it supports only the target environment as .NET 4. My project is in .NET 6 and hence I was not able to use the NCo. I cannot downgrade for now because other dependencies issues as well.

Accepted Solutions (1)

Accepted Solutions (1)

Product and Topic Expert
Product and Topic Expert

You are not using the .NET Connector (NCo), but an open source project that is based on NW RFC Library. The NW RFC SDK comes with the required ICU libraries, so all you would need to do is to make sure that the "lib" directory of your 64bit NW RFC SDK installation is in the PATH environment variable.

BTW: your screenshot shows an error: you must not put the name of a DLL into the PATH, (like "C:\Workspace\Repo\...\icuuc50.dll"), but only the directory containing the DLL! (So in this case "C:\Workspace\Repo\..." would have to be in the PATH.

0 Kudos

Hi ,

You are right. Adding only till directory works. Thanks 🙂

Answers (0)