cancel
Showing results for 
Search instead for 
Did you mean: 

Trouble using BPM

Former Member
0 Kudos
50

Hi everybody,

I configured my scenario like this:

System A (File Sender) > BPM = first Receiver Determination

BPM > System B (File Sender) = second Receiver Determination

Interface Determination, Sender and Receiver Agreement were done as well.

When I triggered the process and checked in SXMB_MONI, only the first part of the process is done (processed successfully). It seems that the IS is not finding the second part and it is stopping in there.

Could someone help me?

Thanks in advance

Leo

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Check SXMB_MONI_BPE

or scroll in SXMB_MONI horizontal. There is a link on <PE>. I guess there is a read flag?

Also sxi_cache: Check if returncode of your process = 0

Regards Mario

Former Member
0 Kudos

Thanks for your answer Mario

In SXMB_MONI_BPE there is no monitoring for my process.

In SXMB_MONI/link on PE, a qRFC Monitor (Inbound Queue) is showed empty: Nothing Selected.

Yes, my returncode is 0 in SXI_CACHE.

Former Member
0 Kudos

Hi leonardo

Try to check the file adapter in the adapter framework.

you can see if there is any error when it writing the file in the target

Regards

Noelia

Former Member
0 Kudos

Hi Leonardo,

Second receiver determination not working means system has encountered some error in your BPM.

In sxmb_moni, for your entry, plz check for the 'PE' indicator somewhere in right hand side.

Click on the PE indicator, it should take you to your process. There you can see what steps have executed successfully and which step is in error.

But if you do not see the 'PE' indicator in sxmb_moni

then plz check the return code in sxi_cache Or check the transaction

SWF_XI_CUSTOMIZING. It should have green status.

Regards,

Seema

Former Member
0 Kudos

Thanks for your answer Seema,

my BPM is very simple, just one Receiver and one Sender steps. When I checked it (F7), there is no erro message.

The PE indicator in transaction SXMB_MONI don´t link me with anything.

In transaction SWF_XI_CUSTOMIZING the Maintain Runtime Enviroment node has two flags with erro: 1. Schedule Background Job For Missed Deadlines and 2. Schedule Background Job For Deadlines Monitoring.

Any clue?

Former Member
0 Kudos

Thanks for your answer Noelia,

when you say "<i>Try to check the file adapter in the adapter framework</i>", do you mean in RWB?

Former Member
0 Kudos

Hi Leonardo,

As u said that in SWF_XI_CUSTOMIZING, there are 2 flags in error, this means there are some settings missed out while carrying post-installation of XI.

and if swf_xi_customizing is in error, then none of ur BPM scenarios should work.

are your other BPM scenarios working? u can check by doing some simple file-file scenario using BPM. if that's not working this means all the settings are not done during post-installation of XI.

Answers (2)

Answers (2)

Former Member
0 Kudos

Thank you for everybody answers

I´ve made all configuration in transaction SWF_XI_CUSTOMIZING and my scenario is working fine,

best regards

Leo

moorthy
Active Contributor
0 Kudos

Hi,

In addition to otehr points discussed-

1) Change the BPM and activate it . Brfore this check for the syntax error

2) Check the configuration in the IntegratioN Directory.. Check the Receiver Determination between Sender Business Service and Receiver Business Service. In this case, Receiver Service should be BPM. Also check BPM to File Target.

Because I think,as per your comments, BPM is not triggered...

3) Go to SXI_CACHE and check the status of the BPM. Does return value is 0 ? if not activate this

This blog may give some hints-

/people/krishna.moorthyp/blog/2005/06/09/walkthrough-with-bpm

Regards,

Moorthy

Former Member
0 Kudos

Thanks for your answer Krishna,

I made all the things that you told me but my scenario keep not working.

It could be missing some configuration?

Former Member
0 Kudos

Hi,

In your integration directory, go to Tools->test configuration and test the entire scenario there.

If there is any kind of error in the interface determination, receiver agreement or receiver determination, it would be shown there.

Also make sure that the containers specified in the BPM have a payload within it at runtime.

For example, make sure that the container you have specified at the send step has some value(payload) within it. You can do this, by checking it in SXMB_MONI_BPE transaction.

Regards,

Smitha.

moorthy
Active Contributor
0 Kudos

HI,

Just verify your scenario with this blog-

/people/krishna.moorthyp/blog/2005/06/09/walkthrough-with-bpm

And also try to do the Integration Directory configuration again for this scenaio by deleting old one. Probably the cache refresh problem..

Thanks,

Moorthy