cancel
Showing results for 
Search instead for 
Did you mean: 

Transport hung and running for long time - Tried most options

0 Kudos

Dear All,

  1. Transport hung and running for long time. And I could able to see the below logs .

(DB0KK906395.QAS is already in use (1020), I'm waiting 5 sec (20140831231754). My name: pid 4112 on)

  1. I’m able to find multiple tp process at OS level and I’ve killed all and even restarted the sap but no luck .
  2. tp updated to latest .
  3. In the /tmp, I can see the transport which I’m trying to import . But when I tried to delete it gets recreated as it should be .
  4. I’ve renamed the buffer , refreshed the STMS queue and tried to add back the transport and tried reimporting but the import monitor shows Main_import running for long time .

  There are no >LOB files in the /tmp folder .

5. RDDIMPDP is running , TRJOB and TRBAT are empty . No Sm12 locks .



Attached is the screenshot , Request your help asap as  we are in the middle of testing .


Regards

Sam

Accepted Solutions (1)

Accepted Solutions (1)

bxiv
Active Contributor
0 Kudos

Kill all your tp processes, go into that tmp folder that you have in your screenshot and move those files into a backup folder, start the process again.

Answers (2)

Answers (2)

Former Member
0 Kudos

If you are using windows server, then you may required to reboot the OS also to delete the content from tmp and you have to move TR manually

Reagan
Product and Topic Expert
Product and Topic Expert
0 Kudos

Kill the TP process

Delete the file which is mentioned in the log file that says "in use"

Connect to the SAP system and call Tx STMS - Select the system and then select the "Import Monitor" for that system.

Delete the TR entry from there.

Start the transport again.

Also read this SAP note

12746 - WARN <file> is already in use (), I'm waiting 5 sec

Regards

RB