cancel
Showing results for 
Search instead for 
Did you mean: 

Time dependent selection

Former Member
0 Kudos
95

Hi,

Can anybody help me with me problem?

I'm creating a datasource for a characteristic with time dependent attributes.

I need to have 0DATEFROM as a selection characteristic in the infopackage.

But when I do this, the load fails with the next error mesage: " ZEMPLOYEE : Data record 1 ('01000001 ') : Invalid "from" date '00000000 '". And the same error appears for all values of ZEMPLOYEE.

Does anybody how to solve the problem?

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Elena,

If you need today date, create a formula in transfer rules: SY-DATUM for the date in question.

There is no need to make this field selectable.

Best regards,

Eugene

Former Member
0 Kudos

Hi Eugene,

In the future, when the system will be in production, the date will be SY-DATUM but for probes and for loading historical data I need to include the date manually

Thanks

PD: Why can I assign to you only 2 or 10 points, the option helpful is not available!

Message was edited by: Elena

Former Member
0 Kudos

Elena,

nice to see your problem solved!

Anyway, in these forums you can assign only one 'problem solved', two 'very helpful' and no limit for 'helpful' answers...

See you next time !

Bye,

Roberto

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi Elena,

Do you load master or transactional data?

If the latter, you need to load master data of 0EMPLOYEE first. The date supplied by the system you need to use in TO_DATE field. The system will take care about creating time-dependent records.

See some examples here:

Best regards,

Eugene

Former Member
0 Kudos

Hi Eugene,

I'm loading master data. I think the problem is that my extractor (function module) returns this field in blank and I would need the value I write in the infopackage selection.

Regards

Former Member
0 Kudos

Try to put 01/01/1900 instead of 00/00/0000 !

Hope it helps!

Bye,

Roberto

Former Member
0 Kudos

Hi Roberto,

I cannot put this date. When doing myself datasource the date doesn´t appear in the Update Tab (as Time-Dependent Data). It just appears in Selection Tab as a normal entry. And in this entry date I need to put today’s date. But I don´t know why the system reads the registry 00.00.0000. It happens for every datasource that I have created, I usually solve this problem unchecking the box for selection in datum fields but in this case I need to include it.

Thanks in advance,

Elena

Former Member
0 Kudos

What about changing this '00000000' in something else in the start routine of your transfer rules ?

Hope it helps!

Bye,

Roberto